OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.

Phi Xenon memory allocation troubles (OS Windows)

Ivan_A_1
Beginner
142 Views

Hello! I use OpenCl XE 2013 r2 driver (OS Windows) with SMPP 3.1.

We have some troubles with memory allocation at Phi Device. There is a simple test:

1) Allocate 100 MB buffer on device

2) Fill buffer with test data

3) Free buffer

4) Sleep 1 second

5) Run Loop again

We control memory usage with MicSmc-gui utility. After 60 loops there is full memory usage on device, but no exceptions like "not enough memory". After that we launch our real application with opencl usage and recieve Build Kernel exceptions. MicSmc-gui displays some system activity on each processor.  I think, that there is some strange clReleaseMemObject behaviour in our case. Maby current OpenCL driver works bad with smpp 3.1.

Thanks.

0 Kudos
1 Reply
Yuri_K_Intel
Employee
142 Views
Hi Ivan, I cannot reproduce such behavior by the steps that you specified. So I would like to ask you for a minimal reproducer for this problem. Could you please also post 'micinfo' command output? I was also going to ask you to try the version of MPSS that was recommended to be used with this release - 2.1.6720-19, see http://software.intel.com/en-us/articles/intel-sdk-for-opencl-applications-xe-2013-release-notes#_In... for the link. But I have checked both this and 3.1 version and I don't observe the issue. Thanks, Yuri
Reply