Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Janusz_R_
Beginner
80 Views

2016R2 breaks OpenCL 1.2 CPU support

I've installed 2016R2 (had previously installed 2015Rx).

The following is reported on my Windows 7:

Intel(R) Corporation OpenCL 1.2     
 - Intel(R) Core(TM) i7-3520M CPU @ 2.90GHz  
 - Intel(R) HD Graphics 4000

Intel(R) Corporation OpenCL 2.1     
- Intel(R) Core(TM) i7-3520M CPU @ 2.90GHz

However OpenCL 1.2 CPU stopped working. Although CPU device is found the context fails to be created:

Context::Context() failed (CL_DEVICE_NOT_AVAILABLE)

This problem should be easily reproducible using CodeBuilder Project for Windows VS2015 template. Compilation fails on:

1>------ Build started: Project: OpenCLProject2, Configuration: Release Win32 ------
1>  Preprocessing: Template.cl
1>  Ignoring -TARGETOS option - not supported for current CPU runtime version
1>  Setting target instruction set architecture to: Default (Advanced Vector Extension (AVX))
1>C:\dev\OpenCLProject2\Template.cl : error CL: Failed to create context for OpenCL Intel CPU device...: -2 (CL_DEVICE_NOT_AVAILABLE)
1>  Build failed!
1>
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\BuildCustomizations\IntelOpenCL.targets(98,5): error MSB3721: The command ""C:\Program Files (x86)\Intel\OpenCL SDK\6.1\bin\x86\ioc32.exe" -cmd=build -input="C:\dev\OpenCLProject2\Template.cl" -output="Release\Template.out" -VS -device=CPU -simd=default -targetos=current            -bo="           "" exited with code -1.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

 

0 Kudos
2 Replies
Robert_I_Intel
Employee
80 Views

Hi Janusz,

Could you please let me know what graphics driver are you using?

Could you please install the latest and greatest driver from here: https://downloadcenter.intel.com/product/81499/Intel-HD-Graphics-4000-for-3rd-Generation-Intel-Core-... and let me know the results?

Thanks! 

Janusz_R_
Beginner
80 Views

Hi Robert,

The previous graphic driver version was: 10.18.10.3958.
Updating to the latest (
10.18.10.4425) fixed the problem.

Thanks.