Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
23 Views

BOINC platform, SETI@Home can't run Radeon Vega M dGPU because of OpenCL issue

Hi folks, quick system description:

Dell Precision M5530 2-in-1 with Intel 8706G, HD 630 + Radeon Pro WX Vega M.

This system used to be able to process BOINC SETI@Home GPU units without a problem several months ago, but it appears that now it's unable to process, possibly due to unabling to find or enumerate the AMD GPU?  

WIth every Intel GPU update I install, it breaks OpenCL so I have to re-install the AMD driver again just so BlackMagic DaVinci Resolve video editor would work, so I am guessing that now something got smudged up bad enough that BOINC won't work (can only do CPU work units).

Running on device number: 0
Priority of worker thread raised successfully
Priority of process adjusted successfully, below normal priority class used
OpenCL platform detected: Advanced Micro Devices, Inc.
BOINC assigns device 0
0 slot of 64 used for this instance
Info: BOINC provided OpenCL device ID used
ERROR: OpenCL kernel/call 'Creating Command Queue. (clCreateCommandQueue)' call failed (-6) in file ..\..\..\src\GPU_lock.cpp near line 1358.
Waiting 30 sec before restart...

 

After looking at this thread, I can't find anything with Khronos in my registry so I could change the REG_DWORD value to keep the Intel platform from enumerating.

https://software.intel.com/en-us/forums/opencl/topic/705036

Any other way I can fix or disable the Intel OpenCL?

0 Kudos
1 Reply
Highlighted
Employee
23 Views

Hi Carlos,

Modern "DCH" drivers use a different registry location than the one described in:

https://software.intel.com/en-us/forums/opencl/topic/705036

The OpenCL-related registry keys are now in the "HKR" section of the registry.  This is a bit tougher to find, but the relevant registry keys for 64-bit apps are:

  • HKLM\SYSTEM\CurrentControlSet\Control\Class\ {Display Adapter GUID}\{Instance ID}\OpenCLDriverName, or
  • HKLM\SYSTEM\CurrentControlSet\Control\Class\ {Software Component GUID}\{Instance ID}\OpenCLDriverName

Or, for 32-bit apps:

  • HKLM\SYSTEM\CurrentControlSet\Control\Class\ {Display Adapter GUID}\{Instance ID}\OpenCLDriverNameWoW, or

  • HKLM\SYSTEM\CurrentControlSet\Control\Class\ {Software Component GUID}\{Instance ID}\OpenCLDriverNameWoW

For Intel OpenCL, these should be set to a full path to IntelOpenCL64.dll and IntelOpenCL32.dll, respectively.  If you rename these registry keys, or change the value of them, then the Intel OpenCL platform should be disabled.

All this being said, I'd really like to fix this issue, so it's not something you need to do each time you update your Intel GPU drivers, and so other users don't experience the same problem.  Would it be possible to write up a short set of reproduction steps so we can debug this problem in-house?  Feel free to contact me via email or a private message if you would prefer.  Thanks!

0 Kudos