Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
45 Views

Blanks debugging Windows in Microsoft Visual Studio

 

I have installed the latest Intel SDK for OpenCL on my windows 7 machine (Core processor and HD 4000 Graphics).

I had no problem with the plugin for either MVS2010 (pro version) or MVS2013 (community version): the API Tracer, The Queue Viewer, The Object Tree were all giving me information.

However, all of a sudden my applications still compile and work, but those debugging windows are blank. I was pretty sure it must be a driver issue, but no matter what OpenCL run time I install (32-bit, 64-bit, whatever the driver update utility recommends,..,), it doesn't resolve the situation: those debug windows have no info in them anymore... any hints as to how start debugging what is really going on?

0 Kudos
11 Replies
Highlighted
Employee
45 Views

Dirk,

What worked for me in the past is fully uninstalling and reinstalling Intel(R) INDE: it sometimes gets confused when I update to a new driver. Your mileage may vary, of course.

0 Kudos
Highlighted
45 Views

Thank you Robert, if I may impose:

1. Did you have the same problem, where the debug windows in Microsoft Visual Studio just blank out? My interpretation is that the API/driver just returns empty information, so there is nothing to display (because the application *does* run).

2. I actually did uninstall and reinstall everything twice now, but I didn't keep track of which drivers that I tried it with... I'll be busy for a few hours... Do you happen to remember if you downloaded your drivers, or just did whatever the Driver Update Utility recommends?

I would feel better if I knew I am not the only person who has observed this particular symptom.

0 Kudos
Highlighted
45 Views

Thank you Robert, if I may impose:

1. Did you have the same problem, where the debug windows in Microsoft Visual Studio just blank out? My interpretation is that the API/driver just returns empty information, so there is nothing to display (because the application *does* run).

2. I actually did uninstall and reinstall everything twice now, but I didn't keep track of which drivers that I tried it with... I'll be busy for a few hours... Do you happen to remember if you downloaded your drivers, or just did whatever the Driver Update Utility recommends?

I would feel better if I knew I am not the only person who has observed this particular symptom.

0 Kudos
Highlighted
Employee
45 Views

I haven't seen blanking out problem: what I saw is my tools stopped working at some point, so I had to uninstall and reinstall them. You can just skip IDE integration and then select Code Builder, which will install all relevant OpenCL tools.

Try installing October 24, 2014 driver from this page https://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProdId=3712 (15.33.30.3958) - that was pretty stable.

0 Kudos
Highlighted
45 Views

I have tried the following, unfortunately still not resolving my blank window problem:

1. Remove (with Revo Uninstaller):

1.1 Intel OpenCL SDK for OpenCL

1.2 Microsoft Visual Studio 2010 Professional.

1.3 Microsoft Visual Studio 2013 Community

2. Reboot

3. Install the Oct.24/2014 driver for Windows-7/64-bit. I selected NOT to have WinSAT (and hence Windows Areo Theme)

4. Reboot

5. Install MVS 2013 Community (Only option selected is the MSF classes for C++).

6. Reboot

7. Install Intel SDK for OpenCL (Only option selected is plugin for MSV2013)

8. Reboot

The debug windows still blank out. I selected a couple of different resolutions (16 bit/32 bit), which doesn't impact the symptoms of my problem.

I need to stress that this all worked just fine for months... I am trying to figure out what I did that could break a working flow, but aside from the drivers, nothing comes to mind.

0 Kudos
Highlighted
45 Views

I removed (with revo uninstaller):

1. Intel SDK for OpenCL.

2. Intel Compiler Platform (which has MVC plugins).

3. OpenCL runtime from Intel (so no graphics driver installed)

4. Any remaining OpenCL related DLL in System32 and SysWOW64

I ran CCleaner until there were no issues in my registry.

Then I reinstalled, in this order:

1. OpenCL runtime

2. MVC 2010 SP1

3. MVC 2013 Community

4. Intel SDK for OpenCL

 

Still the same problem: fully functional OpenCL applications, but I can't debug them anymore...

0 Kudos
Highlighted
45 Views

And it is time to go to the Altar of "I can't believe I did that"

For some reason, my API debugger was just disabled. I don't know why (I had enabled it a LONG time ago, in all of my projects). I never thought about going back to:

CODE-BUILDER>OpenCL Debugger>Options|API Debugger

and just enable all of my settings again...

 

So now it becomes an issue of: why is there no diagnostic when I turn on the debugging windows, to tell me: "I can't show anything because you don't have API Debugging enabled!!!!).

0 Kudos
Highlighted
Employee
45 Views

Dirk,

I am glad you were able to resolve the issue! I will check w/ the developers: you bring up a valid point - there should be a warning if Debugging is not enabled and you attempt to use it.

Thanks for bringing this issue up!

0 Kudos
Highlighted
Beginner
45 Views

I'm getting the same issue. First I upgraded to VS2015, then I installed Intel Fortran. I have a solution with 5 projects, two are in C++, and 3 are in Fortran. I was finally able to get the solution to compile and run. However, in the solution explorer, if I double-click on any of the .cpp, .h, or .f files, I get a tab with that file name on it, but it is blank. .txt files and .cs files are OK, but not Fortran or C++.

Dirk's answer above made no sense to me.

 

0 Kudos
Highlighted
Beginner
45 Views

Weird. I shut down the machine overnight. Rebooted this morning, and now it works!

0 Kudos
Highlighted
45 Views

Hello Michael:

We might have a different problem: my problem was that I didn't see the visualization for the API (object tree view, trace view,...); From your description, I think your problem is that the source code for the host side is blanked out.

The reason why those API visualization windows didn't have content for me, was simply because I had not turned on the API debugging feature...

With my current setup (Microsoft 2015 community with OpenCL Code Builder 6.0.0.1049, the command to do so is:

Click in the menu for "Code Builder>OpenCL Debugger>Options"; Select "API Debugger" tab; Check the "Enable OpenCL Kernel Debugging for CPU device" option.

 

Your problem would be unrelated to this, but it seems that the solution explorer might point to files that are no longer there (maybe you moved the project, or the source code files, around?).

0 Kudos