Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
32 Views

MS VS2017 warning message after installing OpenCL package

After installing the recent OpenCL package by executing intel_aocl_setup_7.0.0.2519.exe, I reveive the warning message

'The Scc Display Information' package did not load correctly

after starting either MS Visual Studio 2015 or 2017. Both have got all recent updates.

Computer is MS Surface Pro 4, i5 6300, HD 520 graphics, Windows 10.

According to https://stackoverflow.com/questions/36358630/visual-studio-2015-with-update-2-the-scc-display-inform... I could not find a registry's HKLM key: SOFTWARE\WOW6432Node\SourceCodeControlProvider.

I do not experience any negative influence for now. The test package intel_ocl_caps_basic_win is running well.

What may be the reason for this message and how to avoid it?

Holger

0 Kudos
11 Replies
Highlighted
Beginner
32 Views

+1

Same issue.

I've been seeing the same warning message with both the new and prior SDKs.  Currently running new SDK on VS2017.

0 Kudos
Highlighted
Beginner
32 Views

Any news? I have the same issue.

Fully updated VS2017 (15.4.0) with intel_aocl_setup_7.0.0.2519.exe.

0 Kudos
Highlighted
32 Views

Same issue here. And issue has been there for more than a year...

If I switch off all Visual Studio Addins (because I know about this problem), why can't this &$*! installer keep its hands of my Visual Studio installation?

...switching back to AMD APP SDK...

0 Kudos
Highlighted
Beginner
32 Views

Just installed the latest OpenCL SDK on MSVS 2017, same problem.

0 Kudos
Highlighted
Beginner
32 Views

Same, latest SDK and latest VS (15.8.4).

0 Kudos
Highlighted
32 Views

All,

Thanks for bumping the thread. This has been filed to the SDK dev team for guidance... case number 3460.

-MichaelC

 

0 Kudos
Highlighted
Beginner
32 Views

same, after install intel_sdk_for_opencl_2017_7.0.0.2567.exe When can you fix this?
0 Kudos
Highlighted
32 Views

Hello JeremieI,

Thanks for the interest.

The case has been accepted by the dev team. Can't provide an eta as a mitigation is open ended, and there may need to be collaboration with external parties as indicated by the stack overflow thread. When there is a change I'll push to have the devs add the announcement to release notes.

-MichaelC

0 Kudos
Highlighted
32 Views

Thanks, Michael.  I just signed up, downloaded and installed OpenCL SDK, same as in Quote #8, same error.  Uninstalled and the error is gone.  I am moving on without the SDK until it's resolved, SCC operation within Visual Studio is important to us.  Any way to be notified when "case number 3460" is updated?

Victor

0 Kudos
Highlighted
32 Views

Hello VictorB/All,

Thanks for continuing communication on this thread.

Yesterday, our dev team provided an update on their reproductions of the issue... they suggested:

  • Users are encouraged to backup any IDE configuration data before attempting any of the guidance. 
  • 'devenv.exe /RootSuffix Exp' launched an MSVS instance that provided a workaround that may be appropriate for some users.
    • I've checked the launch and was able to still use facilities of the IDE OpenCL™ plugins. Any user feedback to the contrary would be appreciated.
  • Our dev team will continue to investigate more comprehensive solutions, both internally and in collaboration with external parties.

Thanks,

-MichaelC

0 Kudos
Highlighted
32 Views

Hello.

Any update on this one? Provided workaround with launching experimental environment started to generate same error after a couple of days.

Right now the workaround for me is to disable "Intel Debugger for Heterogeneous Compute" extension.

0 Kudos