Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
38 Views

OpenCL Code Builder and runtime vs MPSS version

Hi,

we would like to provide OpenCL support to Intel Core and Xeon processors and Intel Xeon Phi coprocessors on our cluster. On the online documentation I read that "For Intel® Xeon Phi™ coprocessor support, you must install the OpenCL runtime 14.2 here, and the Intel® Manycore Platform Software Stack (Intel® MPSS) 3.3 here".

Our cluster has around 380 nodes, each node equipped with 2 octa-core Intel(R) Xeon(R) CPU E5-2630 v3 @ 2.40GHz and 2 16GB Intel Xeon-Phi 7120P Accelerator. The OS is CentOS Linux release 7.0.1406, and the MPSS is 3.5-1 version.

I read on a very old post (https://software.intel.com/en-us/forums/topic/536938) that "I (Yuri Kulakov,Intel) may just confirm information regarding approved MPSS version. Intel OpenCL™ Runtime 14.2 was validated with MPSS 3.3 (as per release notes)", apologies if I missed additional posts on the matter. Since that post dates back to last year, I was wondering if it still applies, in particular:

1) does it mean that the OpenCL runtime won't work with our MPSS 3.5?

or

2) does it mean that we cannot know if it will work - hence we can try to install the Runtime and the Code Builder?

Thank you very much in advance,

Isabella

0 Kudos
2 Replies
Highlighted
Employee
38 Views

Hi Isabella, We didn't test Intel OpenCL™ Runtime 14.2 with MPSS 3.5, so there is no information if such combination will work or not. On the other hand, to maximize performance for Xeon CPUs it is better to use Intel OpenCL™ Runtime 15.1, which contains a number of performance optimizations. Thanks, Yuri
0 Kudos
Highlighted
Beginner
38 Views

thanks a lot, I'll give it a try

cheers

Isabella

0 Kudos