Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
53 Views

OpenCL kernel Buider: Error occured, IOC engine crashed

Hi Intel OpenCL Developmen Team,

I've strange crash in OpenCL kernel Buider.

1. Installed the latest 64-bit OpenCL 2013 SDK.

2. Open Application Kernel Builder version 3.0.0.1 32 bit or 64 bit.

3. Type simple kernel like: void f(float a) {}

4. Press Build, targeting Intel CPU.

Then I get this error: Error occured, IOC engine crashed

What does it mean? What should I do to fix it?

Do you need any extra information from me to check what in wrong?

Thanks,

0 Kudos
6 Replies
Highlighted
Employee
53 Views

Hi,

I could not reproduce this failure.

Can you please tell me:

1. If you had older SDK installed before you installed the latest one?

2. What is your system configuration (Hardware,OS)?

3. Did you use any special build options?

By the way, if you don't use the keyword "kernel" or "__kernel" this is not a kernel but just a simple function. It should compile anyway.

0 Kudos
Highlighted
Beginner
53 Views

Hi,

1. Yes, I use to have old version of Intel SDK before. I've have been using it for more then two years.

2. The latest SDK I've installed about half a month ago and I am pretty sure that I've seen OpenCL kernel Builder working after the installation.

I've played with it and did some experiments with the my OpenCL code. Then, I was not using it for a while and get back to it yesterday.

And it stopped working completely, reporting this error. It does not matter what code you load to it, any build or compile operation will get this message.

3. I am not using any build options. Enabling any options or switching anything in the Builder options does not help.

4. I've CUDA 5.0 installed, but that was installed in December and they used to coexist with no problem.

5. IMPORTANT, three days ago I've installed the latest NVIDIA driver 320.18 with 'clean installation' option. That is the only change on this system during this days. I think that this could be related, since NVIDIA driver has OpenCL dll's to be installed as well. And I am not sure what NVidia will do when the 'clean' option has been selected, which system files and setting that nice installer will remove.

6. I will send you my system log from DirectX Diagnostic Tool and environment variables by mail.

I suspect that NVIDIA driver could spoil some previous Intel OpenCL SDK installation.

Will reinstall Intel OpenCL SDK and report if that helps.

Thanks, Denis

0 Kudos
Highlighted
Beginner
53 Views

Hi,

I've reinstalled the Intel OpenCL SDK 64 bit and the problem is fixed. My system is Windows 7 64 bit.

Everything works again. The kernel Builder works fine now.

As a short conclusion, after installation of NVidia driver with option 'clean install' you may see this error:

Error occured, IOC engine crashed. During building OpenCL code with Intel's OpenCL kernel Builder.

You could make a note somewhere or bug report to fix it for future releases.

Thanks, Denis.

0 Kudos
Highlighted
Beginner
53 Views

Hi

 

I have this error when I try to analyze a kernel. The build is fine.

 

Problem signature:
  Problem Event Name:    APPCRASH
  Application Name:    KernelBuilder64.exe
  Application Version:    3.0.1.15611
  Application Timestamp:    5294801b
  Fault Module Name:    StackHash_1e37
  Fault Module Version:    0.0.0.0
  Fault Module Timestamp:    00000000
  Exception Code:    c0000005
  Exception Offset:    00000000034202c6
  OS Version:    6.1.7601.2.1.0.256.48
  Locale ID:    1033
  Additional Information 1:    1e37
  Additional Information 2:    1e373e69fff075aed81f57003e66ce10
  Additional Information 3:    9f0e
  Additional Information 4:    9f0e095f32a88249d7a2b7eca4e322ea

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt

0 Kudos
Highlighted
Employee
53 Views

Hi,

Please supply more data.

What is the kernel?

What is the data you assign to each argument?

What global/Local sizes did you use?

I can see that your application version is 3.0, can you try to upgrade to the 2014 version and try again?

 

Thanks

Arik

0 Kudos
Highlighted
Beginner
53 Views

its a simple 2d convolution kernel

I used global 1024 by 1024 and set local to auto.

thanks

//KERNEL_SIMPLE
__kernel void Convolve(const __global  float * pInput,
                        __constant float * pFilter,
                        __global  float * pOutput,
                        const int nInWidth,
                        const int nFilterWidth)
{
    const int nWidth = get_global_size(0);

    const int xOut = get_global_id(0);
    const int yOut = get_global_id(1);

    const int xInTopLeft = xOut;
    const int yInTopLeft = yOut;

    float sum = 0;
    for (int r = 0; r < nFilterWidth; r++)
    {
        const int idxFtmp = r * nFilterWidth;

        const int yIn = yInTopLeft + r;
        const int idxIntmp = yIn * nInWidth + xInTopLeft;

        for (int c = 0; c < nFilterWidth; c++)
        {
            const int idxF  = idxFtmp  + c;
            const int idxIn = idxIntmp + c;
            sum += pFilter[idxF]*pInput[idxIn];
        }
    }
    const int idxOut = yOut * nWidth + xOut;
    pOutput[idxOut] = sum;
}
//KERNEL_SIMPLE

0 Kudos