Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ABoxe
Beginner
52 Views

Relative include paths don't work in clBuildProgram

I am using the 2014 beta SDK.  

I would like to pass "-I  RELATIVE\\PATH\\TO\\FILES" in as a build parameters, but this doesn't work.

I have to pass the absolute path instead. So, this forces me to hard code the build path, which is annoying

when I try building from a different location.

Thanks,

Aaron

0 Kudos
4 Replies
Yuri_K_Intel
Employee
52 Views

Hi, I can't reproduce this issue (I'm using 2013 version of the SDK though, but I don't think this is important here). I have created a kernel file with single line: #include "kernel.cl" And I'm passing relative path in build options to clBuildProgram like this for example: "-I..\\..\\FolderWithKernels" And it works fine. So please double check that you're passing correct path. Thanks, Yuri
ABoxe
Beginner
52 Views

Thanks, Yuri.  I should clarify: this is only a problem when targetting my AMD GPU using the Intel SDK. 

When I target the Intel CPU, I don't even need to enter an include path. 

Cheers,

Aaron

 

 

Yuri_K_Intel
Employee
52 Views

In this case you should ask this question on AMD forum. Since when you run the application and, as you say - target AMD GPU, you're selecting AMD platform (and the device, of course), so it's AMD runtime which builds the cl program. Thanks, Yuri
ABoxe
Beginner
52 Views

OK, thanks Yuri.