Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
43 Views

Unknown Problem installing SDK on Windows 7

Hi,

I've just tried to install Intel SDK for OpenCL Applications 2013 on Windows 7 Home Premium. The processor is an i5-M480.

Is there a log file generated during intallation? Mine fails because of "an error" and I've no idea why.

Is "Core" the same as i3 i5 i7? I seem to be missing something here.

nick

0 Kudos
13 Replies
Highlighted
43 Views

Hi Nick,

Unfortunately the GPU device on this processor is not supported. You can try installing the CPU runtime. That should work.

Thanks,
Raghu

0 Kudos
Highlighted
Employee
43 Views

Hi Nick,

You can generate log file by running the following command line : msiexec /i [FULL PATH TO MSI PACAKGE] /lvx* log.txt

You'll need to uncheck the "Remove temporarily extracted files after installation" when launching the SDK installer to get the msi package (will be located under \Intel® SDK for OpenCL Applications 2013\x64\intel_sdk_for_ocl_applications_2013_x64.msi)

Thanks,

Uri 

0 Kudos
Highlighted
Beginner
43 Views

Thanks Uri,

I got the log file... no idea what it means. The bottom bit looks like this:

Property(C): EXECUTEACTION = INSTALL
Property(C): ROOTDRIVE = C:\
Property(C): CostingComplete = 1
Property(C): OutOfDiskSpace = 0
Property(C): OutOfNoRbDiskSpace = 0
Property(C): PrimaryVolumeSpaceAvailable = 0
Property(C): PrimaryVolumeSpaceRequired = 0
Property(C): PrimaryVolumeSpaceRemaining = 0
Property(C): INSTALLLEVEL = 1
=== Logging stopped: 19/04/2013 22:02:20 ===
MSI (c) (98:7C) [22:02:20:572]: Note: 1: 1708
MSI (c) (98:7C) [22:02:20:572]: Note: 1: 2205 2: 3: Error
MSI (c) (98:7C) [22:02:20:572]: Note: 1: 2228 2: 3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1708
MSI (c) (98:7C) [22:02:20:572]: Note: 1: 2205 2: 3: Error
MSI (c) (98:7C) [22:02:20:573]: Note: 1: 2228 2: 3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709
MSI (c) (98:7C) [22:02:20:573]: Product: Intel® SDK for OpenCL* Applications 2013 -- Installation failed.

MSI (c) (98:7C) [22:02:20:576]: Windows Installer installed the product. Product Name: Intel® SDK for OpenCL* Applications 2013. Product Version: 3.0.0.64050. Product Language: 1033. Manufacturer: Intel Corporation. Installation success or error status: 1603.

MSI (c) (98:7C) [22:02:20:577]: Grabbed execution mutex.
MSI (c) (98:7C) [22:02:20:577]: Cleaning up uninstalled install packages, if any exist
MSI (c) (98:7C) [22:02:20:578]: MainEngineThread is returning 1603
=== Verbose logging stopped: 19/04/2013 22:02:20 ===

Could you give a clue what is happening from this (the whole file is attached)?

nick

0 Kudos
Highlighted
Employee
43 Views

Hi Nick,

We've investigated your case and it apears that the installation failed while trying to apply the MS VS2010 integration part.

Which MS VS2010 version are you using?

Can you please try re-installing VS2010 and than try to install our SDK again?

Thanks,

Uri

0 Kudos
Highlighted
Beginner
43 Views

I was asked to post my problem here, so here it is.

The following contains the errors from the log.txt file
And I have uploaded the entire log file.

=== Logging stopped: 24/04/2013 15:44:14 ===
MSI (c) (1C:50) [15:44:14:854]: Note: 1: 1708 
MSI (c) (1C:50) [15:44:14:854]: Note: 1: 2205 2: 3: Error 
MSI (c) (1C:50) [15:44:14:854]: Note: 1: 2228 2: 3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1708 
MSI (c) (1C:50) [15:44:14:854]: Note: 1: 2205 2: 3: Error 
MSI (c) (1C:50) [15:44:14:854]: Note: 1: 2228 2: 3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709 
MSI (c) (1C:50) [15:44:14:854]: Product: Intel® SDK for OpenCL* Applications 2013 -- Installation failed.

MSI (c) (1C:50) [15:44:14:854]: Windows Installer installed the product. Product Name: Intel® SDK for OpenCL* Applications 2013. Product Version: 3.0.0.64050. Product Language: 1033. Manufacturer: Intel Corporation. Installation success or error status: 1603.

MSI (c) (1C:50) [15:44:14:869]: Grabbed execution mutex.
MSI (c) (1C:50) [15:44:14:869]: Cleaning up uninstalled install packages, if any exist
MSI (c) (1C:50) [15:44:14:869]: MainEngineThread is returning 1603
=== Verbose logging stopped: 24/04/2013 15:44:14 ===

0 Kudos
Highlighted
Beginner
43 Views

Hi,

The VS 2010 version (from the About box) that I'm using is:

Microsoft Visual Studio 2010
Version 10.0.40219.1 SP1Rel
Microsoft .NET Framework
Version 4.5.50709 SP1Rel

Installed Version: VC Express

Microsoft Visual C++ 2010 01013-169-2610014-70110
Microsoft Visual C++ 2010

Hotfix for Microsoft Visual C++ 2010 Express - ENU (KB2542054) KB2542054
This hotfix is for Microsoft Visual C++ 2010 Express - ENU.
If you later install a more recent service pack, this hotfix will be uninstalled automatically.
For more information, visit http://support.microsoft.com/kb/2542054.

Hotfix for Microsoft Visual C++ 2010 Express - ENU (KB2635973) KB2635973
This hotfix is for Microsoft Visual C++ 2010 Express - ENU.
If you later install a more recent service pack, this hotfix will be uninstalled automatically.
For more information, visit http://support.microsoft.com/kb/2635973.

Microsoft Visual C++ 2010 Express - ENU Service Pack 1 (KB983509) KB983509
This service pack is for Microsoft Visual C++ 2010 Express - ENU.
If you later install a more recent service pack, this service pack will be uninstalled automatically.
For more information, visit http://support.microsoft.com/kb/983509.

I loaded the SDK successfully without VS 2010 integration and then reinstalled VS2010 and it aborted. Seems that there is a problem there.

I'm going to stop now. I've got two intel processors and neither are supported by the SDK so I don't see any point in any further struggle.

I'd like to wish you guys all the best with your product. I know that it will be great one day. The support here is been second to none - just absolutley great!

If I could make one observation - your web site is letting you down. It is frustrating to look for compatability information, see that the E5 family is supported, try it out and then find out that your particular version isn't. Then, looking at the i5 compatability, find that while the core is the graphics processor isn't. The information is difficult to find and then impossible to interpret - I have no idea what the various versions of the i5 core are and what graphics processors they come with. It is frustrating to see something that looks like it will work and then find out that it doesn't.

Can I suggest that you do something like the nVidia scan tool (http://www.nvidia.com/Download/Scan.aspx?lang=en-us). That would have saved me a whole lot of frustration.

nick

0 Kudos
Highlighted
43 Views

Nick,

Sorry for your frustrating experience. We'll consider your suggestions and will try to better document supported devices going forward.

Thanks,
Raghu

0 Kudos
Highlighted
Beginner
43 Views

Hi Raghu,

it's been a while since the posts above. Unfortunately the issue still exists since I am encountering the same problem:

When installing the ocl sdk without integration of MSVC10 everything seems to work.

When installing the ocl sdk with integration of MSVC10 the installation aborts without any meaningful hint.

I created a logfile as suggested and get errors corresponding to above:

......

=== Logging stopped: 07.01.2014  17:41:21 ===
MSI (c) (D8:20) [17:41:21:525]: Note: 1: 1708
MSI (c) (D8:20) [17:41:21:525]: Note: 1: 2205 2:  3: Error
MSI (c) (D8:20) [17:41:21:525]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1708
MSI (c) (D8:20) [17:41:21:525]: Note: 1: 2205 2:  3: Error
MSI (c) (D8:20) [17:41:21:525]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709
MSI (c) (D8:20) [17:41:21:525]: Product: Intel® SDK for OpenCL* Applications 2013 -- Installation failed.

MSI (c) (D8:20) [17:41:21:525]: Windows Installer installed the product. Product Name: Intel® SDK for OpenCL* Applications 2013. Product Version: 3.0.0.81147. Product Language: 1033. Manufacturer: Intel Corporation. Installation success or error status: 1603.

MSI (c) (D8:20) [17:41:21:525]: Grabbed execution mutex.
MSI (c) (D8:20) [17:41:21:525]: Cleaning up uninstalled install packages, if any exist
MSI (c) (D8:20) [17:41:21:540]: MainEngineThread is returning 1603

Is there a solution yet? What can I do to make the installer conclude?

Thanks,

Daniel

0 Kudos
Highlighted
Beginner
43 Views

Hi Raghu,

is there any solution to this OpenCL-SDK and MSVC integration issue? I am encountering the same problem (i.e. installation with Option "integration" fails) with respective log-file entries (c.f. above). Therefore I would appreciate a quick and handy solution or at least a workaround.

Thanks,

Daniel

0 Kudos
Highlighted
Beginner
43 Views

Raghu,

I forgot to mention my CPU device, etc.:

Intel Core i7-3520M

Windows 7

MSVC C++ V10 Express

Daniel

0 Kudos
Highlighted
43 Views

Daniel,

Let me forward your question to the tools team. We'll get back to you soon.

Raghu

0 Kudos
Highlighted
Employee
43 Views

Hi Daniel,

Our SDK doesn't support VS Express edition.

In order to work with our plug-in you will need use one of the following versions: Professional, Premium or Ultimate.

Thanks,

Uri

0 Kudos
Highlighted
Beginner
43 Views

Hi Uri,

thanks for the reply. Not supporting the Express Version is sad for the user.

However, I managed to integrate with MSVC 10 Express with the following trick:

1. Run installer to unpack the installation routines.

2. Install SDK without MSVC 10 integration by manually running msi-file.

3. Repair installation by manually running msi-file and selecting the integration option.

Could you please confirm?

Thanks,

Daniel

0 Kudos