Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
40 Views

x64 build of OpenCL SDK in SystemStudio 2019 update 2 got exception

I'm trying to use the latest opencl sdk in System Studio 2019 update 2 on ApolloLake platform.

But the app get exception at clGetPlatformIDs(0, NULL, &numPlatforms) under x64 mode, there is no issue at the x86 mode.

If the sdk is uninstalled and reinstalled with 2017 R2. There is no exception thrown out.

So there must be something wrong with the OpenCL SDK 2019.

0 Kudos
1 Reply
Highlighted
40 Views

Hi SimonLi,

Thanks for the feedback.

Can you clarify what you mean by 'the app'? Do you mean the plugin functionality provided by the OpenCL tools within MSVS2017? Or do you mean an OpenCL application you build in x86 or x64 mode that attempts to enumerate? Or something else?

This could be a conflict among CPU runtimes. It's highly recommended to remove any 'Experimental' labeled Intel runtimes as they are known to conflict with the production Intel CPU runtime for OpenCL Applications that replaced it. 'Experimental' runtimes were removed as part of SDK install in recent releases of the 2019 SDK.

If you can attach some screen shots or console output from the session that could be very useful.

This information from the registry, along side a description about what SDKs are installed is very useful if you can share it:

  • HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenCL\Vendors
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Khronos\OpenCL\Vendors

Thanks,

-MichaelC

0 Kudos