Processors
Intel® Processors, Tools, and Utilities
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
14271 Discussions

B760 Chipset, Intel VMD, Server 2022 STD and Hyper-V

Marc11b20
Novice
2,893 Views

I have an ASUS Prime B760M-A D4, i7-12700 with BIOS ver. 0807. I have Configured (2) Seagate 2TB SATA HDD in a RAID1 in the BIOS with VMD for SATA enabled. Windows Serer 2022 Standard loads fine and I have no other errors. I have all the latest drivers from ASUS loaded and the latest Windows updates.

This is a  new install on known good hardware. The issue is that when I attempt to load the Hyper-V feature and set the system to reboot, after a good POST and the BIOS hands the system off to the OS, the OS hangs at the blue MS window screen.  It is as if it is hanging on a driver. If I manually shut down and got to the recovery environment and set the system to boot to safe mode, it reboots, attempts safe mode, fails, then reboots and rolls back the Hyper-V install. I have attempted this 2x and get the same results.

Yes, I know this platform is not intended to run a server OS, but we have been running server OSs on "workstation" grade platforms for decades and we understand the performance limitations. So, please do not hide behind that as your answer.

I am applying a tried and true installation procedure that we have used on 300, 400, 500, and 600 series Intel chipsets across Server 12R2, 2016, and 2019.

My question is: Is there and issue with Hyper-V being loaded on a VMD SATA enabled RAID1 configuration?

 

Thank you.

Labels (1)
0 Kudos
4 Replies
DeividA_Intel
Moderator
2,867 Views

Hello Marc11b20,  


  

Thank you for posting on the Intel® communities. I am sorry to know that you are having issues with your Intel® Core™ i7-12700 Processor.   


As you mentioned, this issue could be related to the compatibility of the components. The motherboard does not support Windows servers and even though it can be installed, it could raise unexpected issues. 


Since your Intel® Core™ i7-12700 Processor supports virtualization and you are using a Microsoft tool (Hyper-V), I recommend you to check with Microsoft to confirm if there are any issues with the tool and the VMD SATA and to confirm if there are any driver updates for your RAID configuration.


You can also check the tool requirements:



Please keep in mind that this thread will no longer be monitored by Intel.  


Regards,  

Deivid A.  

Intel Customer Support Technician 


0 Kudos
Marc11b20
Novice
2,828 Views

Deivid:

 

Thank you for letting me know this mobo is not designed for Windows Server. We certainly understand that element and have chosen to press forward with the configuration attempt as we have done in the past. I have looked at the suggestions you recommended, and my configuration is set to allow Hyper-V to install as it has in all previous iterations from the 600 chipset down to the 100 chipset. I was not concerned that the i7-12700 was at fault, but rather the new instruction set regarding VRoC and VMD. These are the new wrinkle in the UEFI/BIOS configuration that hides the RAID array behind a new layer. Systems that used IRSTe do not have this problem.

I have installed Hyper-V for Windows 10 on the aforementioned configuration without issue. So, my question is, what is it about the VRoC/VMD instructions that allow Hyper-V to function with Windows 10 and not Server 2022 on this platform?

 

Hopefully you will receive this inquiry.

 

Thank you.

 

 

0 Kudos
kuchiii
Beginner
2,330 Views

Hi Marc,

I wanted to ask you if you could help or guide me. As I read your post that your build is ASUS Prime B760M-A D4, i7-12700. I have almost the same motherboard Asus Prime B760-PLUS D4 and I am having trouble installing Windows Server 2022 Standard because I cannot find the appropriate drivers for the disk controller.

I tried to go through everything on the Internet, but without success. That's why when I read your post that your installation works on this build, I thought of asking you for help.

 

Thank you

0 Kudos
Marc11b20
Novice
2,315 Views

kuchiii:

 

Sorry to hear you are running into issues as well. My issue turned out to be a faulty Windows Server 2022 Feb 2023 Cumulative Update KB5022842. Though MS never officially declared that they "fixed" this particular issue w/ Hyper-V, the update was superseded by the March 2022 CU KB5023705 about a week after I posted about this. I know this might sound trite but download and load the latest drivers from the ASUS global site for your mobo. I have found that the global site tends to have newer divers than the country specific sites.

 

https://www.asus.com/motherboards-components/motherboards/prime/prime-b760m-a-d4-csm/helpdesk_knowledge/?model2Name=PRIME-B760M-A-D4-CSM

 

I did find this article to be helpful:

>>>>>>>>>>>>>>>>>>>>>>>

"Environment
11th Generation and later Intel® platforms
Operating System
Windows 11, 64-bit*, Windows® 10, 64-bit*
BUILT IN - ARTICLE INTRO SECOND COMPONENT
Summary
How to install a new Windows® 10 Operating System on a system with drives managed by Intel® VolumeManagement Device (Intel® VMD)
Description
When installing the Windows* operating system, no storage drives are available to select for the destination drive.
Resolution
Follow the instructions below to properly detect available storage drives for OS installation.
1. Download Intel® RST driver packages F6flpy-x64(Intel® VMD).zip and F6flpy-x64(Intel® Non-Intel®VMD).zip, both folders separately to a USB flash drive. (I use the drivers from the ASUS global site personally)
2. Start the Windows® 10\11 64-bit OS Installation process.
3. Load the Intel® RST driver from step 1."

>>>>>>>>>>>>>>>>>>>>>>>>

I have attached a driver set that has been working for me. I download the OS ISO, use Rufus-3.10 to create a UEFI GPT USB 3.0 bootable version of the ISO and then create folders with SATA, VROC f-6, and LAN drivers for each motherboard I work with. 

As an unrelated sidebar - If you don't like having the reserve partition at the end of an 10/11/22 OS install, I have attached a zipped set of files that includes a .bat file and two supporting .txt files with instructions on how to create a better arranged set of partitions during OS install. No warranty or responsibility for affects to your system(s) given or implied. Use at your own discretion. Yes, it is a .bat file and not PowerShell. I am an old-school PC hack/builder from the 1990s. Don't make me smack you with my 12 inch 512K ISA slot video card! 

YMMV - hope this helps.  

 

0 Kudos
Reply