Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JCast19
Beginner
1,119 Views

Can't get Turbo Boost back after XTU

Hi guys, I have a problem with my laptop. I have a 2017 MBP 15-inch model (MacBookPro14,3) with an Intel Intel Core i7 7820HQ processor and wanted to use XTU to slow down the processor a bit (so it doesn't get toasty while I'm running Boot Camp). However, after updating the settings back to default (for more intensive tasks) the processor will not Turbo Boost again, it stays at it's base 2.9 GHz clock speed (~2.897GHz). Even after resetting everything back to the default profile, uninstalling XTU and doing a clean reinstall... the CPU will not Turbo Boost on Windows. It does work fine under macOS, as I've tried running Cinebench r15 and I can see it Turbo Boosting up to 3.5Ghz there... so not sure why it won't do it on Windows - and I'm out of ideas. Do you have any suggestions for me to follow?

This is my first time posting here so I'm not sure if it's the right place to ask about XTU, so apologies in advance!

Thanks!

Tags (1)
0 Kudos
1 Reply
idata
Community Manager
132 Views

Hello trkplaster,

 

 

Thank you for joining this Intel Community.

 

 

Even though you are using Windows* operating system through Boot Camp, the system is still running on an Apple* platform. In this case, Apple* has requested for all support inquiries to be addressed directly to them.

 

 

https://support.apple.com/ Apple* support

 

 

Wanner G.

 

Intel Customer Support Technician

 

Under Contract to Intel Corporation
Reply