Processors
Processors (Intel® Core™, Intel® Xeon®, etc); processor utilities and programs (Intel® Processor Identification Utility, Intel® Extreme Tuning Utility, Intel® Easy Streaming Wizard, etc.)
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
12346 Discussions

Fortran, Vtune Profiler and 'do_alloc_copy'

AxelHuebner
Beginner
127 Views

Dear community,

 

I'm running a Fortran program, on a Linux system (2 cores, 2.4GHz) and try to optimize it's performance using the VTune Profiler. I've executed a hotspot and a microarch exploration analysis and got

intel_comm_picture.png

The leading contributions here are 'do_alloc_copy' and 'copy_src_xdesc_to_dest_xdesc', the third is from my code.

According to VTune, 'do_alloc_copy' and 'copy_src_xdesc_to_dest_xdesc' belong to no module, and have no source file. The top-down tree and caller/callee table do not help me find where they are called at all. There is no call stack information.

I then isolated the function, where they seem to occur. If I call it twice, the execution time for 'do_alloc_copy' and 'copy_src_xdesc_to_dest_xdesc' doubles, roughly. (Unfortunately, the routine has about 2000 lines, and calls many user functions. It's automatically written code for quantum mechanics calculations.)

Now, looking into this source file, VTune says, there are no real hotspots. Nothing that could explain this contribution.

I can imagine what both functions do. But I don't know, what exactly they do, and when they are called.

Can you send me a reference, where these functions are explained?

Or can anybody tell me, what I can do with VTune,  to understand where these calls occur?

Apparently I'm doing something wrong here. So I try to fix it and keep you posted (espc. if it is a stupid mistake by me. There is a good chance for that.)

Thanks a lot!

Axel

 

UPDATE

First of all, sorry that I posted this in the wrong spot.

Then: I'm running VTune without drivers. Fortunately you guys explain here what to do then. Collecting stacks and looking into the red rectangle below

vtune2.png

solved the problem for me. Sorry for bothering you.

0 Kudos
1 Reply
AndrewG_Intel
Moderator
95 Views

Hello @AxelHuebner

Thank you for posting on the Intel® communities. No problem, we are glad to know that you were able to find a solution to this.

Since you mentioned the issue is solved, we will proceed to close this request now. If you need any additional information, please submit a new question as this thread will no longer be monitored.


Best regards,

Andrew G.

Intel Customer Support Technician


Reply