Processors
Processors (Intel® Core™, Intel® Xeon®, etc); processor utilities and programs (Intel® Processor Identification Utility, Intel® Extreme Tuning Utility, Intel® Easy Streaming Wizard, etc.)
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
12370 Discussions

How can I reduce the CPU turbo (not off)

Kiprey
Beginner
441 Views

My laptop is equipped with an i7-9750H CPU with a main frequency of 2.60GHz and a maximum turbo frequency of 4.5GHz.

When it is not externally powered, the maximum CPU frequency is limited to 3.5GHz (data measured multiple times), which is very good to balance heat and fan noise.

But!!! Once it is connected to the power supply, the frequency limit is unlocked immediately and the CPU frequency often reach 4.0 plus GHz.

Despite performing better performance in a short period of time, unlocking also brings rapidly rising temperatures. Although the CPU is fast,it often reach 70 to 80 degrees Celsius (no program is running much)

The end result is that the CPU will downfrequency, performance is reduced, and the fan noise is very loud, the keyboard is very hot. Finally, the performance when laptop is powered ,is poor than the performance when laptop is not powered, in a long period of time. So, I want to ask a question:

How can I reduce the CPU turbo (not off)

0 Kudos
6 Replies
LeonWaksman
Super User
131 Views

Open: Settings > System > Power & sleep > Additional power settings (on R.H. side) > Change plan settings > Change advanced power settings. Click on Processor power management and change the "Maximum processor state".

 

Leon

 

Kiprey
Beginner
131 Views

I am sorry to tell you that the "Processor power management" option does not exist in windows 10 system.

LeonWaksman
Super User
131 Views

I am sorry to tell you that you are wrong 😄 Follow my instructions and you will find it.

 

Leon

PowerOptions.png

Kiprey
Beginner
131 Views

T_T  

the "Processor power management" option really does not exist in my laptop.....

Maybe it's because my Windows OS is professional.

I'm not sure

 Kiprey.

AlHill
Super User
131 Views

Contact the manufacturer of your laptop for support and help with your bios settings.

 

Doc

 

Kiprey
Beginner
131 Views

OK, I will give it a try.

Reply