Intel® Processors, Tools, and Utilities
13885 Discussions

Intel® Driver & Support Assistant


Hi, I have been having problems with the driver for a few weeks now. 


When I clicked on Check For New Drivers



I've tried reinstalling, but nothing helps...

Labels (1)
0 Kudos
5 Replies
Valued Contributor I

Try this:

1. Uninstall the current DSA tool using the Uninstaller tool:

2. Clear your browser cache

3. Then download and install the latest DSA version:


0 Kudos
Thanks for your reply. I already try this, but didn't work...
0 Kudos

Hello @aeonspoke

Thank you for posting on the Intel® communities.

In addition to the previous recommendations from the community, could you please also try the following steps:

a- Check Intel® Driver & Support Assistant (Intel® DSA) service:

  • Ensure both the Intel® DSA Service and Intel® DSA Updater service show status of Running.
    • In Windows* Search, type Services and scroll to find Intel® Driver & Support Assistant.
    • Confirm the Status shows Running; if it isn't Running, then start the service if necessary by right-clicking and choosing Start.
  • Check to see if any Windows* updates are pending.
  • Restart the system.

b- Clear the browser cache and close the browser.

c- Try rescanning Intel® DSA, ensuring the browser being used is Firefox, Chrome, or Edge Legacy.

d- Try disabling your Ad Blocking extensions and privacy-related extension (if any) on the Intel® DSA webpage.

If the behavior persists, please provide us with the following information:

1- Did Intel® DSA work fine before? If it did, were there any hardware or software changes (drivers, OS, BIOS, or software updates) that may relate to the point when the behavior started?

2- Do you have security or anti-virus software installed, if yes, please provide details:

3- Attach in a .zip file the full Intel® DSA folders following the steps in this article: How to Obtain the Intel® Driver & Support Assistant (Intel® DSA) Folders?

4- An Intel® System Support Utility (Intel® SSU) report to gather more details about the system:

  • Download the Intel® SSU and save the application on your computer
  • Open the application, check the "Everything" checkbox, and click "Scan" to see the system and device information. The Intel® SSU defaults to the "Summary View" on the output screen following the scan. Click the menu where it says "Summary" to change to "Detailed View".
  • To save your scan, click Next and click Save.
  • Once you have saved the file (.txt file), please attach it to your reply.

To upload and attach a file, use the "Drag and drop here or browse files to attach" option below the response textbox.

Best regards,

Andrew G.

Intel Customer Support Technician

0 Kudos

I found what the problem was


IDSA can't accesses localhost on ports 28385-28389


I run these commands with admin privilegies " netsh http add iplisten net stop DSAService && net start DSAService " 


and everything works fine now


Thanks a lot for your time!

0 Kudos

Hello aeonspoke

Thank you for your response.

Your findings are correct. Intel® DSA needs to access localhost on ports 28385-28389 as noted in this article: Things to Know Before I Start to Use the Intel® Driver & Support Assistant (Intel® DSA).

We are glad to know that you were able to find the root cause of the problem and a solution. We really appreciate you took the time to share this feedback. Hopefully, it may help other users experiencing similar behavior.

Since the issue has been solved now, we will proceed to close this thread now. If you need any additional information, please submit a new question as this thread will no longer be monitored.

Best regards,

Andrew G.

Intel Customer Support Technician

0 Kudos