Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AChan76
Beginner
17,704 Views

Intel HD graphics 3000, windows 10, not working !!!!!!!!!

Jump to solution

I have a Dell Vostro 3350. My intel 15-2450 processor (64bit) has an intel HD graphics 3000. This driver is not supported on windows 10. The driver gets installed, but the laptop screen turns black. However, when I connect my laptop to an external monitor, it works. What seems to be the problem? Is there a fix? Does Intel have a windows 10 driver for this processor graphics?


Accepted Solutions
DMcDe
Novice
12,113 Views

After going to Settings in Windows 10 and Updating my computer I have a valid HD 3000 driver with external VGA access. Thank you!

View solution in original post

10 Replies
JCole9
Beginner
12,113 Views

I am having the same issue with the Intel 3000 Graphics Driver. Anyone know a fix?

AChan76
Beginner
12,113 Views

Hello Everyone,

I found a fix for this issue that worked for me. Check out your BIOS version. You can find this in command prompt by typing wmic bios get smbiosbiosversion.

Then check if this is the latest BIOS version available for your mother board. You can find this from your laptop manufacturer homepage. Flash your BIOS to the newest version and then restart your laptop. My display started working and it was running the HD graphics 3000.

jimACP

EJenk
Beginner
12,113 Views

Just updated my laptop from win7 to win10 yesterday. Use an external display (it should work right out the gate) then go to device manager > display adapters and disable INTEL HD 3000. You won't have 1080p, and you won't be able to use an external/secondary display, but the laptop will work until Intel makes a patch to fix this issue.

TSkon
Beginner
12,113 Views

H/W: Dell Vostro 3350

GPU: Intel HD Graphics 3000 / AMD Radeon HD 7400M Series

Driver: 9.17.10.4229 / 15.200.1062.1004

OS: Windows 10 Pro 64-bit

CPU: Intel Core i7-2640M CPU @ 2.80GHz

On default W10 Intel drivers for HD 3000 there was no support for Intel QSV (insane fast hardware H264 encoding in short, e.g. below result after applying new drivers):

[13:07:32] work: average encoding speed for job is 271.954529 fps.

 

For me the solution was to replace default Windows 10 Intel drivers for HD 3000 (provided by M$ via Windows Update) and replace them with customized ones for HD 3000:

"Catalyst UnifL – Catalyst Unified Leshcat Drivers" [ http://leshcatlabs.net/unifl-unified-leshcat-drivers/ http://leshcatlabs.net/unifl-unified-leshcat-drivers/ ]

Since then QSV encoding in Handbrake and q264 in Windows 10 works like a charm !

Results:

 

Handbrake:

HandBrake Nightly 20150924194455-e7912cc-master (2015092401) - 64bit Version

OS: Microsoft Windows NT 6.2.9200.0 - 64bit

CPU: Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz

Ram: 16291 MB,

GPU Information:

AMD Radeon HD 7400M Series - 15.200.1062.1004

Intel(R) HD Graphics 3000 - 9.17.10.4229

Screen: 1366x768

Temp Dir: C:\Users\tskon\AppData\Local\Temp\

Install Dir: C:\Program Files\HandBrake

Data Dir: C:\Users\tskon\AppData\Roaming\HandBrake Team\HandBrake\0.0.0.0

-------------------------------------------

# Starting Scan ...

[12:34:43] CPU: Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz

[12:34:43] - Intel microarchitecture Sandy Bridge

[12:34:43] - logical processor count: 4

[12:34:53] OpenCL device # 1: Advanced Micro Devices, Inc. Caicos

[12:34:53] - OpenCL version: 1.2 AMD-APP (1800.8)

[12:34:53] - driver version: 1800.8 (VM)

[12:34:53] - device type: GPU

[12:34:53] - supported: YES

[12:34:53] Intel Quick Sync Video support: yes

[12:34:53] - Intel Media SDK hardware: API 1.4 (minimum: 1.3)

[12:34:53] - H.264 encoder: yes

[12:34:53] - preferred implementation: hardware (any)

[12:34:53] - capabilities (hardware): vsinfo opt1

[12:34:53] - H.265 encoder: no

 

Q264:

C:\Program Files (x86)\q264>q264.exe -info

2015-09-28 13:18:49.512: Info: Main: Build: q264 Version 0.4.4 Built: Apr 29 2015 11:00:33

2015-09-28 13:18:49.824: Info: Main: Intel HD graphics driver: Intel(R) HD Graphics 3000

2015-09-28 13:18:49.825: Info: Main: Intel HD driver version: 9.17.10.4229

2015-09-28 13:18:49.826: Info: Main: CPU Caps: MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2, AVX,

2015-09-28 13:18:51.824: Info: Main: Highest Quick Sync hardware API version: 1.4

2015-09-28 13:18:51.825: Info: Main: Highest software API version: 1.9

 

For those having Intel HD 3000 with NVidia or just Intel HD 3000 - there is no need to apply AMD Catalyst drivers - you just run Leshcat installer to uninstall pack of drivers (AMD + Intel) and later just install Intel ones (manually or via setup.exe).
DMcDe
Novice
12,114 Views

After going to Settings in Windows 10 and Updating my computer I have a valid HD 3000 driver with external VGA access. Thank you!

View solution in original post

EstebanA_C_Intel
Employee
12,113 Views

Hello, All:

I am glad to hear this is working for you.

If you require any further information or support, feel free to contact the Intel Communities back.

Regards,

Esteban C

idata
Community Manager
12,113 Views

I followed you advice, but in programs designed to work with Quick Sync, it is still disabled. What did I do wrong. Hope you will reply with suggestions. Thanks

idata
Community Manager
12,113 Views

I see this post started before Anniversary update of Windows 10. I found a solution that has allowed me to be able to use the Intel Quick Sync with the HD3000 driver (Sandy Bridge). Used DDU: http://www.majorgeeks.com/mg/getmirror/display_driver_uninstaller,2.html Download Display Driver Uninstaller 17.0.3.0 . Uninstalled in safe mode also reinstalled in compatibility mode Windows 8, Now all features of driver 9.17.10.4229 are working as expected without problem due to driver not being updated for Windows 10.

idata
Community Manager
12,113 Views

I think Microsoft has fixed this issue an updated HD 3000 display driver for Windows 10

Pepe
Beginner
1,311 Views

guys,just right click on your desktop,then enter your graphics properties and set refresh rate to 40p Hz.

or do the same thing in right click display settings ...regards