Showing results for 
Search instead for 
Did you mean: 
Community Manager

Intel Management Engine Failure, Broadwell-E

I have an ASRock Fatal1ty X99 Professional Gaming i7 with a Broadwell-E. I used the manufacturer-supplied INF and ME packages, but am stuck with device status: This device cannot start. (Code 10) STATUS_DEVICE_POWER_FAILURE. IMEI version is displayed as when installing with the manufacturer-supplied package v11.0.4.1186. Using IMEI package v11.0.6.1194 gives me ME version, which also has the same error. I have tried re-running the INF installer and ME package installers with negative results. I have also tried going down to a single RAM stick (and switching them), switching the PSU, and re-seating everything. There are no other issues apparent in device manager except for IMEI.

Attached is the Intel SSU system information file for this system. I am out of ideas of how to get this fixed. Can anyone help?

0 Kudos
3 Replies
Community Manager

Hello EpsilonZero ,


Thank you for letting me know about the troubleshooting that you have performed with the system!

Please remember that Intel stopped manufacturing boards a while ago, for that reason, drivers for Intel Management Engine are not released from our side.

There is the option to test the ME drivers for our NUCs; however, I cannot assure they are going to work, because if the driver does not detect the correct chipset, the installation can fail.

ME for NUCs:

When are you getting this error? "STATUS_DEVICE_POWER_FAILURE" is this a blue screen? If possible, could I have a screenshot or picture of the issue?

As per the scenario, this could also be related to the image or ISO used to install Windows 10* in your system, you could run system file checker or if possible perform a clean installation.

System file checker:

If the problem persists after the additional troubleshooting proposed, I recommend checking with the manufacturer of the board.

Hope this can be of help for your issue, and have a great day!

Any further inquiries, let us know.




Esteban C


0 Kudos
Community Manager

System file checker reports no integrity violations. The error is found in device manager (see attachment). Updating the driver with ME installer v11.0.6.1194 updates successfully to ME driver v11.0.5.1189, but the code 10 error remains.Uninstalling while deleting the driver files (in device manager, repeatedly) drops the version down to (as I recall), but the same error 10 appears. Nothing else in device manager is reporting problems.


I did a clean install over the old installation on the same drive (previous install going into windows.old) after booting into the old install (previously different X99 motherboard and Haswell-E).

0 Kudos
Community Manager

Hello EpsilonZero:



Thank you very much for letting us know that information.



At this point to try the driver provided above will be the best option we can try, basically because there is no management engine driver available for chipset X99, which is the one your board has.



So, based on that, the next thing to do will be to get in contact directly with ASrock so they can check on this matter, maybe a BIOS update is needed or they might be able to provide a different solution for this scenario.



Just in case, on the following link you will find the chipset driver from ASrock: osW1032 osW1032



Also on that same link you will find the files to try a BIOS update.



Let me apologize for any inconvenience.



ASrock support site:



ASrock phone number: (909) 590-8308





0 Kudos