Intel® Processors, Tools, and Utilities
13841 Discussions

Intel Proessor Diagnostic Tests fail - and I get a lot of blue screens - What to do?


Hi Community,


I am getting quite some blue screens recently and I have tried to figure out what the issue is. I have already performed a MemTest86 for over 6 hours and the RAM looks fine.

I just now checked the processor with the Intel Processor Diagnostic Tool and the Test always fails with the PrimeNumber Test

CPU1 Parallel_PrimeNum_i7-8 Test Module Version: Start Time: 3/28/2020 12:35:33 AM Test Result - FAIL Parallel_PrimeNum_i7-8 End Time: 3/28/2020 12:35:52 AM --------------------------------------------------------------------   System Information ------------------ Processor Name: Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz Processor Information: Family 6 Model 158 Stepping 10 Number of Physical Cores: 6 Number of Logical Cores: 12 Operating System: Microsoft Windows 10 Pro 64-bit Graphics Information: NVIDIA GeForce RTX 2080 --------------------------------------------------------------------   --- IPDT64 - End Time: 3/28/2020 12:35:52 AM --- IPDT64 - Result: Fail --------------------------------------------------------------------

This is repeatable and since I have started the test and installed other tools from intel for my processor, I have also gotten even more blue screens.


Any suggestion what I should do? Is it necessary to replace the CPU?


Thanks for your help and stay healthy!


0 Kudos
2 Replies
New Contributor I

Check that your operating system is up to date, check Blue screen error with Microsoft for proper diagnostic and load BIOS defaults...

then, check with your PC/motherboard manufacturer if there is a BIOS update and if it is, if the BIOS update is needed or helpul.

If the problem persists, and you bought the CPU to build the PC, request a replacement to intel customer support.

0 Kudos

Hi Gh0stb1t,

I updated Windows 10 fully, I re-installed twice. I even get blue screens during the installation of Windows 10 / booting from an USB stick.

I updated my BIOS to the newest full release - nothing worked. As mentioned, I performed the memory test for 6 1/2 hours without any issues, but the IPDT failed/fails constantly.

I opened a warranty case with Intel, hoping I can replace it (it's only one year old) and that the issues will be resolved then.


If there are any other ideas on what to do, I'll gladly try them.


Thank you!

0 Kudos