Processors (Intel® Core™, Intel® Xeon®, etc); processor utilities and programs (Intel® Processor Identification Utility, Intel® Extreme Tuning Utility, Intel® Easy Streaming Wizard, etc.)
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
12356 Discussions

Intel SGX Driver issue

New Contributor I


The latest Intel SGX Driver broke Cyberlink PowerDVD's SGX support.

It made the PowerDVD unable to enable SGX to play 4K Ultra HD Blu-ray Disc.

The Intel SGX Driver doesn't have this problem but Windows 10 forced updating it to

Can Intel update the driver to fix it?

0 Kudos
7 Replies
New Contributor I

The PC build:

CPU: Core i7 8700

MB: EVGA H370 Stinger

SGX on BIOS: Enabled

(forced Enabled but not Software Controlled because Cyberlink PowerDVD can only enable SGX on forced-enabled statement)


Graphic: UHD630

BD Drive: Pioneer BDR-S11-J-BK

Software: Cyberlink PowerDVD 14 OEM (bundled by the drive)

OS: Windows 10 1709

Intel ME Driver: 1815.12.0.2021

Intel SGX Platform Driver: (OK) (broken)

Community Manager

Hello MelonGx,


Thank you for joining this community; it will be more than a pleasure to assist you.


Based on the information that you provided to us, we noticed that the version that works fine is the


There are two version of this driver, one from Intel ® which is only for Intel ® NUCs and another version from EVGA*, which is customized by your equipment manufacturer.


They both share the same driver number, so can you tell us which of the two versions were you using?


If you were using the Intel ® one, please try reinstalling the OEM version on top of the generic Microsoft* driver ( which is causing the issue.


Here is the direct download:


Please let us know the outcome.




Diego S.


New Contributor I

Thanks for the reply.

I used Gigabyte's & EVGA's (on 2 different harddisks) and both of them work.

But the problem is happened on 2.0 but not 1.9.

I tried uninstalling 2.0 then reinstalling 1.9, but Windows refused and said "AESM service has already installed".

I had to format C: then reinstall a brand new Win10 1709 + SGX 1.9 to make PowerDVD SGX work again.

It seemed that Win10 1803 integrated SGX also had this problem.

I haven't tried installing 1803. If it's true, then if we cannot find a 1709 installer to make installable, we have to wait for Intel's driver update.

BTW I checked all the NUC's, Gigabyte's and EVGA's installers. They shared a same CRC32 checksum. So I think they're just a same file even I haven't tried to use NUC's.

Community Manager

Hello MelonGx,



Thank you for your response.



Unless you have an Intel® NUC, our recommendation is that you can report this issue to your system manufacturer. In this way, they can replicate it using the exact same hardware/driver version and report it to Intel, business-to-business, if there is a problem that may need to be addressed.



I hope you find this information helpful.



Wanner G.

Hello Intel Corporation,

I have same issue as original poster with similar system specs (means same MB).

While I understand your advice to get in contact with our system manufacturer, I still would like to understand why it is not possible to install the SGX driver with version "", when windows automatically installed the driver with version "" from WindowsUpdate. Error message is "AESM service has already installed".

In fact I can downgrade the driver itself from "" to "". But as also the SGX windows service is required, I must install it using the driver, which is not possible due to some restriction in the installer.

I guess that is pure Intel issue independent from the system manufacturer. Could you investigate wheter there is any restriction in the Intel SGX installer? Is this restriction really needed?

In addition, I do not understand why windows update installs a driver which is not suitable for our system. If some specific SGX driver would be needed for EVGA board, then windows update should not install driver only suitable for NUC.

Thank you!

Community Manager

Hello roppp


Thank you for your response.


We totally understand your feedback.


We are currently performing further assistance on this matter.


This will cause a brief delay in between our answers; however I will reach you back as soon as we have an answer.


We really appreciate your patience.



I hope this helps.




Diego S.



Hello my system settings are in this report created from the Intel driver support page.   In short I own a Dell XPS 15 7590 with i7-9750H processor, UHD, and this Lite-On Blu ray player. For software I am using PowerDvD 18 OEM and have SGX enabled in the bios and IME but not able to play 4K Blu ray discs. 


After contacting Cyberlink PowerDvD they advised that I run Ultra HD Blu-Ray Advisor on my laptop to see what is wrong.  

Advisor reports that everything EXCEPT SGX is compatible and working correctly.  SGX is enabled in the Bios as well as 128 MB.  After speaking with a PowerDvD representative about this they replied with the following:

"With reference to your query, please be advised that CyberLink Ultra HD Blu-ray advisor applies the detection tool offered by Intel officially to detect if the security function (Intel SGX, which is required by DRM Ultra HD Blu-ray playback) is properly enabled and operating on your platform.

According to the detection result, the report indicated that the Intel SGX is not properly on your platform.


I would appreciate assistance with getting 4K Blu ray discs to play on my laptop?