Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CBerg5
Beginner
4,068 Views

Intel Turbo Boost Max Technology 3.0 window pops up at boot and never disappears in windows 10.

Ref:

Like the title states, Intel Turbo Boost Max Technology 3.0 window pops up at boot and never disappears in windows 10. I thought it would start minimized?

0 Kudos
19 Replies
idata
Community Manager
495 Views

Blofeld2k: Thank you very much for contacting the Intel® communities. We will do our best to try to fix this problem.

 

 

In regard to your inquiry, what we can try is to un-install the software from control panel, reboot the system and then re-install it again:

 

https://downloadcenter.intel.com/download/26103/Intel-Turbo-Boost-Max-Technology-3-0 https://downloadcenter.intel.com/download/26103/Intel-Turbo-Boost-Max-Technology-3-0

 

 

What is the model of your processor?

 

Which Windows version are you using?

 

 

Additionally, on the link below you will find additional details about the feature:

 

https://downloadcenter.intel.com/download/26103/Intel-Turbo-Boost-Max-Technology-3-0 https://downloadcenter.intel.com/download/26103/Intel-Turbo-Boost-Max-Technology-3-0

 

 

Any further questions, please let me know.

 

 

Regards,

 

Alberto R

 

CBerg5
Beginner
495 Views

Hi Alberto,

I uninstalled and re-installed. No difference.

What is the model of your processor?

Intel Core i7 6800K 3,4GHz

Which Windows version are you using?

Windows 10 Pro

Brgds,

Carl

idata
Community Manager
495 Views

Blofeld2k: Thank you very much for providing that information.

 

 

In order to try to fix this problem we can try a BIOS update to the latest version of the board.

 

 

Most of the times the manufacturer of the board has their own Intel® Turbo boost driver for their platform, did you check with them about this possibility and to confirm if there is a setting on the BIOS that needs to be enabled or disabled?

 

 

What is the model of your board?

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

CBerg5
Beginner
495 Views

Hi Alberto,

even though the problem is not about the "Intel Turbo Boost Max Technology 3.0" not being enabled I did what you asked of me.

My motherboard is "Asus ROG Strix X99 Gaming" and I am using the latest BIOS "Version 1701" released.

There is indeed a setting in the BIOS, "Turbo Mode", but it is still set to its default value "Enabled".

Brgds,

Carl

idata
Community Manager
495 Views

Hi Blofeld2k: Thank you very much for providing that information. We will do further research on this matter, as soon as I get nay updates I will post all the details on this thread.

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

idata
Community Manager
495 Views

Blofeld2k: I just received an update on this matter, we just wanted to confirm if it was a clean Windows® 10 RS3 installation or if it was an upgrade from Windows® 10 RS2 to RS3?

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

CBerg5
Beginner
495 Views

Hi Alberto,

a clean install, no update.

idata
Community Manager
495 Views

Blofeld2k: Thank you very much for your response. We will continue with our research on this subject. I will post all the details on this thread as soon as I get any updates.

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

idata
Community Manager
495 Views

Hi Blofeld2k: I just received an update on this matter, actually the information provided by chemist9999 on post 9 seems to be very accurate, did you followed those steps in order to try to fix the problem?

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

idata
Community Manager
495 Views

Blofeld2k: I just wanted to check if the information posted previously was useful for you and if you need further assistance on this matter?

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

BBerg3
Beginner
495 Views

I have a similar problem, well the same in fact. After installing a second graphics card in SLI my turbo boost now fires up twice and I have tried to uninstall and install the latest version. But windows just installs it automatically. I know you have to disable this feature but in group policy editor and I messed my pc up using that stuff and was forced to do a clean install. The normal use for this is it should fire up for a split second right after boot and disappear just as quick. But it just seems to do that sometimes and other times it just stays up. Now after installing a second card it fires up normal and after a 2-3 min delay another version or same window and or app fires up and stays up and I have to close it manually. Only one icons in my sys tray and device manager only shows it once in systems but who knows. I can honestly say this app gives me this kind of problems all the time. My pc is virtually brand new and still under warranty. Dell doesnt give the latest version when you go into support and driver downloads but in my experience they always lag way behind in drivers and apps when it comes to that sort of thing. I dont know if that makes a difference or not but its weird. I can successfully update the app though by pointing device manager to the most current version but it doesnt have any effect. So I just uninstalled and rebooted to let windows give it what it wants and thats a lower version but higher then what dells page suggests or recommends. Totally confusing to me. It seems if I let my pc go without cleaning it or optimizing it after a couple weeks or several boot ups the intel turbo boost 3.0 app works as intended until I do a clean. But I just installed a new GPU couple days ago and now it fires up twice. Once right at boot and goes away and then after a delay it fires up and stays... I give up.. I'll just close it or never restart my pc which sometimes my pc will go days. I asked windows for help and they said just turn it off but I dont want it off. It was put there for a reason I'm sure. Let me know what you find out.

BBerg3
Beginner
495 Views

if replying to me yes my bios is updated to the latest Alienware A-12. It's a new pc and dells website lags behind for driver updates I think. It doesn't say the latest recommendation for what intel has released. I am trying to update it but I can't do what intel suggest because it auto updates after I restart windows but I haven't messed with group policy editor. As if right now running the edition that windows auto installs which is one less then what intel has released it shows up in tray icon instant and after 5 mins the popup appears and doesn't go away. It's just confusing and sucks. I don't think it's the drivers fault though. It might be windows delaying some apps or drivers. Norton has a startuo manager but all this stuff is off and or not turned on for these. I have no clue and give up honestly. Once upon a time this program used to fire up instant and you would never see it and if so it would auto disappear.

BBerg3
Beginner
495 Views

My intel turbo boost still starts up the same way and even worse because if I close it the first time another one will appear in about 2 minutes during bootup. Its very annoying and nobody has a fix for this one. I have uninstalled and reinstalled but windows auto installs this by it self and I cant force it not to because windows will blue screen during boot saying a critical system cant be loaded. I am forced to use system restore. This seems to have always show up during boot and forced to close manually which I can live with but after installing a second graphics card SLI I now get two of these window apps. I have tried everything.. I do mean everything. I just dont think uninstalling or re installing does anything. Even the latest version does nothing. I only see one icon in system tray though.

HBick
Beginner
495 Views

I was having this same issue. It turns out this is due to a "feature" of a recent windows 10 update where opened programs will reopen in the same state upon starting. To avoid this, when shutting down make sure everything is closed then click on the desktop then hit Alt+F4 to shut down. This will do a shutdown without reopening items. If you shutdown from the start menu the turbo boost will pop up again. There are other ways to avoid it including creating a shutdown shortcut or registry editing and they can be found if you want the old functionality back.

BBerg3
Beginner
495 Views

Ok thanks. I am trying many different things and one of the things I am doing is going into services and turning off the automatic start for this and I set it to manual. I rebooted and even though its changed it still starts auto and it did the same thing the first time. But I am having problems with the latest up for windows 10 that was released on the 12/17/2017 in which my games Halo Wars 2 and Gears of War 4 will not work and or even launch so I have been rebooting and reinstalling and I will keep you posted. I did two reboots and the second one was good because I didn't see the intel turbo boost app pop up once on screen but its still in system tray running and enabled. If it stays like this which I highly doubt as its hit and miss with this app I will be happy but still upset I cant play my games now.. MS will not let us backup our games and installer so we are forced to re download everytime a problems comes up. Its stupid and even MS supports agrees.. Go figure.

RAign
Beginner
495 Views

I'm having the same behaviour. I am currently looking for a way to disable this Windows 10 "feature", however I'm not completely convinced that this is the only reason for the issue as I also get the Intel Turbo Boost Max Technology 3.0 control pannel showing up after booting when it was definitely NOT opened at shutdown-time. Can anybody confirm a successful removal of the control panel window? I also tried uninstalling Intel Turbo Boost Max Technology from Apps & Features, however it shows up again at some point.

idata
Community Manager
495 Views

Hello, iko79. Thank you for joining this thread.

 

 

I sent you a private message, please check your inbox.

 

 

 

Antony S.
RonaldM_Intel
Moderator
495 Views

Hello everyone,

I would like to let you all know that we have released a new version of Intel® Turbo Boost Max Technology (TBMT) 3.0 that should fix this issue.

Please download it from https://downloadcenter.intel.com/download/26103/Intel-Turbo-Boost-Max-Technology-3-0 here and let me know your feedback.

We apologize for the delay getting this fix out, and at the same time thank you for your outstanding patience.

Best Regards

Ronald M.

AChry
Beginner
495 Views

Hi Ronald you asked for feedback some time ago on this issue but I have just got to this problem after updating to latest windows 10 October update. The only difference for me is that I can shut ITBM down after it pops up on the desktop at start up.

I am running an i9-7900x on a Strix X299 mobo with the latest bios (1602).

I downloaded the 1.1.0.1005 zip file from the webpage, I can uninstall the old version of ITBM however when I go to install the latest version (as administrator) I get the error message that the system does not meet the minimum specs for installing the software however when I reboot, the system installs the old version automatically. LOL.

Any suggestions?

Thanks

Reply