Processors
Processors (Intel® Core™, Intel® Xeon®, etc); processor utilities and programs (Intel® Processor Identification Utility, Intel® Extreme Tuning Utility, Intel® Easy Streaming Wizard, etc.)
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
11689 Discussions

Intel Turbo Boost Max Technology

HugoValkenburg
Beginner
332 Views

Hello, everytime I start my PC, I get a message ITBM Driver Not Available Exiting Application. Does anyone know how to fix this?

My specs are:

  • CPU: I7-7820x, With Corsair H115I AIO
  • MB: Asus ROG Strix x299-e gaming
  • RAM: Corsair Dominator DDR4 2x16 3200Mhz, With Corsair dominator platinum airflow (ram cooler)
  • GPU: Asus ROG Strix 1080TI OC 11GB
  • PSU: Corsair HX1200I
  • Fans: 3x AF140L Corsair Fans
  • Case: Corsair Carbide Clear 600c inverted atx
  • DVD Player: LG BH16NS55

 

Thanks in advance,
Hugo

0 Kudos
3 Replies
Esteban_D_Intel
Moderator
309 Views

Hello HugoValkenburg,

Thank you for posting on the Intel® communities.  


I would like to inform you that the Operating system has a native support for the Intel Turbo Boost Max 2.0 when using Windows 10 * (version equal or greater than 1803).


The operating system supports the Intel® Turbo® Boost Max 2.0 so this feature still working and the computer can still benefit from Intel® Turbo® Boost technology.


That being said, I would like to share with you some steps the message:

Go to Windows Control Panel > Programs > Uninstall a Program, and uninstall the Intel® Turbo Boost Max Technology 2.0 software.

  1. Open device manager.
  2. Click in the System devices.
  3. Right click on Intel® Turbo Boost Max Technology 2.0 Driver.
  4. Click in properties.
  5. Go to the driver tab and click uninstall.
  6. Make sure to select the option to Delete the driver software for this device.
  7. Check if the message is gone.


As an alternate solution uncheck the “Enable” button in the ITBM User Interface.

See the steps below:

  1. Go to system tray in your system.
  2. Right click on the Intel Turbo Boost Max Technology icon.
  3. Click "Disable"
  4. No need to reboot.


I hope this helps to answer your concern.


Esteban D.

Intel Technical Support Technician


Alberto_Sykes
Employee
294 Views

Hello HugoValkenburg, I just wanted to check if the information posted previously was useful for you and if you need further assistance on this matter?


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel


Alberto_Sykes
Employee
274 Views

Hello HugoValkenburg, Since I have not heard back from you, we are closing the case, but if you have any additional questions, please post them on a new thread so we can further assist you with this matter.


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel


Reply