Processors
Intel® Processors, Tools, and Utilities
14989 Discussions

Intel XTU - drivers are not running

ElectricUnit
Novice
378 Views

Hello there,

I have a problem with installing Intel Extreme Tuning Utility.

I installed Intel XTU and restarted my PC afterwards.

Next, when I tried to start XTU, the following error message showed up:

Unable to start Intel Extreme Tuning Utility because the driver are not running. A reboot may be necessary if Intel Extreme Tuning Utility was just installed, otherwise download and install the latest version of Intel Extreme Tuning Utility from https://www.intel.com/

 

I already tried uninstalling and installing Intel XTU a few times without success.

After uninstalling no process and files related to XTU remains on my system.

 

Thanks a lot in advance.

 

Here are my system stats if needed:

 

Operating System: Microsoft Windows 10 Education(10.0.19044 Build 19044)

Physical Memory (Installed): 16 GB

Processor: 12th Gen Intel(R) Core(TM) i5-12600K

System Type: x64-based PC

 

Total Installed Updates: 28 Updates - See Detailed View for more information

Display Adapter(s): Intel(R) UHD Graphics 770 30.0.101.1994

                                    NVIDIA GeForce RTX 3070 Ti 31.0.15.1659

 

System Manufacturer: Micro-Star International Co., Ltd.

System Model: MAG Z690 TOMAHAWK WIFI DDR4 (MS-7D32)

 

Network Adapter(s): Bluetooth Device (Personal Area Network) 10.0.19041.1

Intel(R) Ethernet Controller (3) I225-V #2 1.0.2.14

Intel(R) Wi-Fi 6 AX201 160MHz 22.140.0.3

Realtek USB GbE Family Controller 10.50.211.2022

 

Disk(s): Samsung SSD 980 PRO 1TB 572,81 GB (available) 10.0.19041.789

Labels (1)
0 Kudos
0 Replies
Reply