Showing results for 
Search instead for 
Did you mean: 

Lack of Performance for I7-4790kK

I have posted once before about this problem but still have no clear answers about what is going on in my computer. I have a custom build using:

Motherboard: ASRock extreme 6

CPU : I7-4790K

Ram: G.Skill Ripjaw DDR3

GPU: Gigabyte 1070

Cooling: Kraken X97 Watercooler

Storage: sandisk SSD

PSU: CX 750M 80+ Bronze

I noticed that my Laptop using a I7-7700U processor would fluctuate frequency's based on load and temperature, no problems and the laptop runs great. modeling software is a breeze and does exactly what I want it to do. When running my tower, I can tell it is running good but not near on par as my laptop does.

*note my laptop is no where near as powerful as the tower is rated for since they are only a year apart in age*

when running games, modeling software and other applications I notice that my tower is very sluggish in comparison to the laptop. when running a system monitoring software I noticed that the CPU would not change from 800Mhz. I noticed this in 3 different software's including Task manager, CAM, and the Intel CPU Tweaker Extreme. I then did a performance comparison from mu tower to my laptop and found my laptop ran faster and better than my tower did. once I brought this up to the intel community they told me to use the intel CPU test software to ensure the CPU is performing properly and it told me that there was nothing wrong but any time I run any software the clock never changes and continues to be sluggish.

After running countless stress test software's the only one that was able to get my CPU to clock even close to its max clock speed was Aida64. other than that, 0 clock change occurs during standard computer use. in comparison to my laptop the tower appears to be dead. my final step to debugging this issue was to unplug any unnecessary hardware to run the computer to allow it the max power it would need to run in hopes it was a power problem, the issue did not change. performance numbers went up a fractional amount but otherwise was the same. I was told that under everyday use a computer should change frequency's rather often to account for the need on CPU load. and in addition to this, the temperature of the die should change as well. after running stress tests with little hardware, and tried to allow the CPU to go up in temperature, it doesn't budge. the CPU even under Aida64 stress testing does not change its package temperature, and if so it is by a factor of maybe 3 degrees C MAX.

I understand I may be arrogant to the workings of my CPU but I don't understand why my laptop out performed my tower by a landslide during the same tests. being this tower is built for performance and heavy work load it is sad to see my laptop beats it. is there anything I am doing wrong that may allow my tower to not run to proper specs or is this normal for a CPU, and if not what can I do to fix this, is there say a hardware problem, missing software or tuning that needs to be done to allow the proper utilization of my CPU?

0 Kudos
1 Reply
Super User Retired Employee

The primary cause for this phenomenon is a setting in the BIOS that is limiting the maximum frequency. If there are no obvious settings/changes that would explain this, you could check whether resetting the BIOS configuration to defaults will result in better performance. Barring this, I suggest that you check with the ASRock support folks.

Hope this helps,