Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,612 Views

Memory read errors when shutting down Windows 10...

Hi there

A year and a half ago I built this machine:

i7 6700k

Asus Z170 E

16GB Corsair Vengeance LPX 3000mhz

Plextor 128GB SSD

Superclocked EVGA GTX 1060 6GB

EVGA Supernova 750W PSU

Windows 10 64bit

Long story short is for just over a year it was perfect, then about four months ago I started getting memory read errors when shutting down the PC. It's never when I'm using it or when it's idling, it always errors upon shutdown. I raised a ticket with Corsair, they gave me an RMA and I got a new kit of exactly the same memory. Everything was good for about a month then the memory errors came back, again when shutting down only. Both kits return errors when running memtest, though only when running the memory at its rated 3000mhz speeds, running both sticks at 2133mhz the memtest errors disappeared but I still get the memory read errors when shutting down.

Is there anyone out there who can tell me is my CPU somehow damaged, or is it a motherboard issue or am I just really unlucky and got two dodgy kits of memory?

I'm worried about the CPU because I have been getting advice from the overclockers UK forum (I DO NOT OVERCLOCK) but their forum is pretty decent and one helpful user flagged up the vccio and vccsa voltages were too high and that could have damaged my beast of a cpu, is this true?

Can anyone please help me with this?

Tags (1)
0 Kudos
5 Replies
idata
Community Manager
114 Views

Hello steve0307956,

We will do our best to help you with your questions.

The first thing I would like to mentioned regarding this situation is that this processor model only supports memory types DDR4-1866/2133, DDR3L-1333/1600 @ 1.35V. So, it is expected to have errors when running a memory with a higher frecuency.

Can you please let us know where are you seeing the memory errors when shutting down your PC? If possible, share a screenshot of the error messages.

Regards,

Amy C.

idata
Community Manager
114 Views

Thanks for your reply.

I have lowered the memory frequency to 2133, yet still get the error message?

The error message itself is a small window that appears during the blue shutdown screen for Windows 10 saying something like 'The instruction at 0x00007FFA67C5C2AB 0x00007FFA274F3EBO the memory cannot be read' or something along those lines. It doesn't happen every time though so can be difficult to catch.

I would appreciate any further help you can give me.

Thanks.

n_scott_pearson
Super User Retired Employee
114 Views

Ah, this explains things a lot more! The message that you are seeing is not an indication of a hardware (memory) error/failure! It is an indication of some piece of software failing during Windows shutdown.

During shutdown, the Windows kernel tells each running software application to shutdown. They are each given a small amount of time to do so. After this time, they are expected to have completed this shutdown. The Windows kernel then begins forcibly shutting down the lower-level service layers. If an application ignores the shutdown command (or is simply too slow responding to this command) and thus is still running when the service layers that it is using are shutdown, they will lose the resources provided to them by these service layers - and, if they try to use these resources, they will have an access error and abort.

Bottom line, you are seeing a software error, not a hardware (memory) error. There is likely nothing that you can do about this - and this failure should not be hurting anything - so don't worry about it.

As an aside, I will say, however, that you do have some piece of software that is not acting as it is supposed to during shutdown. If you can figure out which piece of software this is, you could inform the creators and have them address this failure in a subsequent release.

Hope this helps - and you feel better now!

...S

idata
Community Manager
114 Views

Oh thank God!

That's a massive worry off my mind; I've been convinced that there was some kind of hardware fault somewhere.

I just need to figure out which program is causing it now.

Thanks a lot!

ggame1
Beginner
114 Views

sharing people also thought it was not okay for me but I handled it when you shared here thanks

---------------------

GamesBX

Reply