Processors
Intel® Processors, Tools, and Utilities
13854 Discussions

NIOS II voltage monitor interrupt Arria 10 quartus 19.4

TSege1
Beginner
698 Views

Hi,

insude a  Qsys with NIOS II I inserted voltage monitor module of altera and connected its IRQ signal to IRQ NIOS II IRQ bus at bit 2 and generated the qsys.

at the Qsys file SOPCINFO the irq looks connected ID=2

but when generating the BSP the iterrupt ID equals to -1 instead of 2.

what can be the problem?any workaround?

 

thanks

 

Tamir S

0 Kudos
8 Replies
BoonBengT_Intel
Moderator
689 Views

Hi @TSege1,

Thank you for posting in Intel community forum and hope you are doing well.
Clarification on the design, you are using the voltage sensor IP and are trying to connect the interrupt interface to NIOS II processor?
Is it possible to share the Qsys design or any NIOS code for our further checking and better understanding?

For the time being here is some useful resource which you can refer to in regards to the design you are using:
- https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/ug/ug_voltagesensor.pdf (refer to the section 4.3 for interrupt interface)
- https://www.youtube.com/watch?v=-2LUJdjXdKk
- https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/nios2/n2sw_nii52006.pdf#page=7&zoom=100,96,592 (Nios II Interrupt Service)

Warm regards.

0 Kudos
TSege1
Beginner
681 Views

Hi,

thanks for your quick response.

please see attached the QSYS design of the NIOS part

0 Kudos
BoonBengT_Intel
Moderator
669 Views

Hi @TSege1,

Noted on the qsys files, allow us to take a look into the design and get back to you shortly.

Further clarification if I may, in where did you see the interrupt ID of -1 in the BSP? (if convenient, please do provide us a screenshot of the mention settings)

 

Thank you.

Warm regards.

0 Kudos
TSege1
Beginner
663 Views

Hi

1. Attached please find screenshots of the BSP interrupt ID.

2. I also tried to make a much more simple design with NIOS2 and voltage monitor in 18.1 version, and still got same result.

 

thanks

 

Noam

0 Kudos
BoonBengT_Intel
Moderator
658 Views

Hi @TSege1,

Did not managed to see any attachment in the last post, screenshot might have missed out.

Help needed to reattached if possible.

 

Warm regards.

0 Kudos
BoonBengT_Intel
Moderator
609 Views

Hi @TSege1,

Good day, regarding the last post, did you managed to look into the attachment mention? As from our end we still did not see the attached screenshot mention.

 

Thank you.

Warm regards.

0 Kudos
BoonBengT_Intel
Moderator
588 Views

Hi @TSege1,

Hope you are doing well, checking in to see if it is possible for you to attached the mention screenshot.

 

Thank you

Warm regards.

0 Kudos
BoonBengT_Intel
Moderator
556 Views

Hi @TSege1,

Hope this message find you well and good day, as we do not receive any response from you to the previous clarification that we have provided. Please post a response in the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you with your follow-up questions. 

 

Warm Regards

BB

0 Kudos
Reply