Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
2,016 Views

New Version of Security Unifier doesnt recognise my CPU

New version of Intel Security Unifier sais that my CPU is not supported.. yet i see it under the supported products - i5 5200U. I ended up lacking the drivers i need.. Any ideas how to fix this guys?

0 Kudos
4 Replies
Highlighted
Community Manager
11 Views

Hello aNdRi3,

 

 

 

What version of Windows are you using?

 

 

This is what is required to install and use the utility:
  1. A broadband Internet connection is required to use this utility.
  2. Operating system requirements for installation: This application installs on Windows* 7, Windows* 8, Windows* 8.1, and Windows® 10.
  3. We recommend that you perform a Windows update to bring your operating system up to date with the latest .NET.

 

Make sure you have the latest Intel® Management engine installed.

You can see more information here:

https://downloadcenter.intel.com/download/25952/Intel-Security-Unifier Download Intel® Security Unifier

 

 

Regards,

 

 

 

Ivan
0 Kudos
Highlighted
Community Manager
11 Views

Got 50mbps internet connection, using Windows 10 with latest updates, got all net framework versions from 2.0 to 4.0, c++ from 2008-2015.

0 Kudos
Highlighted
Community Manager
11 Views

Please allow me to find out who can better assist you with this software.

 

 

 

Regards,

 

 

 

Ivan
Highlighted
Community Manager
11 Views

Hello aNdRi3 ,

 

 

After further investigation, I found out that the tool should only work on Skylake onward (6th generation CPU) and the reason it failed on your systems is because your processor is a Broadwell CPU (5th gen)

 

 

 

Regards,

 

 

 

Ivan.
0 Kudos