Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MDomb
Novice
885 Views

No x2apic on Westmere/Tylersburg

I have a Westmere/Tylersburg system (CPU: 2 x X5672, Chipset: Intel 5520 Tylersburg) - sitting on a Supermicro X8DTN+-F

I believe I should have a x2APIC

lspci says

00:13.0 PIC: Intel Corporation 7500/5520/5500/X58 I/O Hub I/OxAPIC Interrupt Controller (rev 22) (prog-if 20 [IO(X)-APIC])

Both x2apic as well as IRQ rerouting are enabled in my kernel, but unfortunately no x2apic flag is visible in /proc/cpuinfo

Now I read, that the Tylersburg chipset has trouble with IRQ rerouting, which seems a prerequisite for x2APIC operation.

(see: https://www.redhat.com/archives/vfio-users/2016-June/msg00055.html [vfio-users] Intel x2APIC and APIC Virtualization (APICv or vAPIC) ), so I wanted to ask if that's a hardware-given

blocker or if this is again something that could be circumvented by some BIOS settings?

The machine in question has 144GB RAM and I intend to have a quite extensive set of VMs running on it, so I'd naturally

like to make use of x2apic as it gives me quite some difference in VM responsiveness on other machines with x2apic enabled.

0 Kudos
1 Reply
idata
Community Manager
30 Views

Hello marcdom,

I would like to let you know that in this case the right place to the accurate answers regarding your inquiry is; https://www.supermicro.com/support/index.cfm, this since the Intel® Intel® 5520 Chipset is a server chipset and any questions related to it should be handled by Supermicro.

Regards,

Amy C.