Intel® Processors, Tools, and Utilities
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
14275 Discussions

Not able to install Ubuntu 18.04 on Clevo laptop (Intel HM370 rev. 10 and CPU i7-8750


I have a few questions regarding my problems with installation of Ubuntu 18.04 on my laptop. The laptop is based on Clevo N871EJ1 and has the following configuration: chipset Intel HM370 rev. 10, CPU i7-8750H 6 x 2.20 - 4.10GHz Turbo, RAM 16 GB (2 x 8) DDR4 2400 MHz, storage Samsung SSD 512GB 960 Pro NVMe M.2 2280, graphics card NVIDIA GeForce GTX 1050 4GB GDDR5. When trying to install it from USB stick or even loading Live version I could see lots of ACPI-related errors. Live version was loaded but all I could do was moving cursor with touchpad but no touchpad button worked. When I tried to install Ubuntu 18.04 it broke quickly with stack displayed on the screen. Then I used FWTS tool to get some details. It reported a lot of errors, below you can see some of them:



AILED [HIGH] KlogAcpiBadAmlCode: Test 1, HIGH Kernel message: [ 0.010017] ACPI Warning: Unsupported module-level executable opcode 0x70 at table offset 0x34C6A (20150930/psloop-222)   ADVICE: ACPI AML interpreter has found some non-conforming AML code. This should be investigated and fixed.       FAILED [HIGH] KlogAcpiNamespaceLookupFailure: Test 1, HIGH Kernel message: [ 0.259471] ACPI Error: [_SB_.PCI0.RP05.PXSX] Namespace lookup failure, AE_NOT_FOUND (20150930/dswload2-191)   ADVICE: The kernel has detected an error trying to execute an Method and it cannot find an object. This is indicates a bug in the DSDT or SSDT AML code.       FAILED [HIGH] KlogAcpiObjectNotFound: Test 1, HIGH Kernel message: [ 0.259479] ACPI Error: Method parse/execution failed [\_SB.PCI0.RP04.PXSX] (Node ffff88046ccca230), AE_NOT_FOUND (20150930/psparse-542)   ADVICE: This is a bug picked up by the kernel, but as yet, the firmware test suite has no diagnostic advice for this particular problem.



I have the whole report available.

Just a note: I also tried Ubuntu 16.04 but with the same effect. 


I was looking for some ACPI-related BIOS/UEFI settings but I found BIOS/UEFI (vendor: American Megatrends Inc., version: 5.13, released on 04/13/2018) to be very simple with none option related to ACPI.

Here's my questions:


1. Shall it be possible to overcome these issues with some changes to BIOS/UEFI only (meaning no update of kernel required)?

2. If answer to above question is "No" what is the chance that a new version of kernel with fix will be released in near future?


I understand that my hardware is fairly new but more and more laptops with 8th gen high voltage core i7 CPUs are expected to show up soon so the problem might not be limited to a single user.

Thank you for any help.

0 Kudos
3 Replies
Super User

You need to contact clevo for support, or use the linux community for support.

The bios is Clevo's, not intel's.

Clevo is solely responsible for support of your laptop. Your laptop is a clevo product, not an Intel product.



0 Kudos
Super User

Also, wrong forum. Probably should be in the processors forum.




0 Kudos

Thanks, I've moved the thread to the Processors forum and notified that team in case they can help. Thanks!

Mary T.

Community Manager

0 Kudos