Processors
Processors (Intel® Core™, Intel® Xeon®, etc); processor utilities and programs (Intel® Processor Identification Utility, Intel® Extreme Tuning Utility, Intel® Easy Streaming Wizard, etc.)
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
12345 Discussions

Number of Cores Incorrect - i3-7100 @ 3.9GHz

KDayl
Beginner
1,567 Views

Sincerely I didn't realize that I had only been using a single core and I've had this CPU installed for about a year now. After running various identification programs including the Intel Processor Diagnostic Tool, I show that I only have 1 Physical Core and 2 Logical Cores/Processors.

I have seen a few other posts with similar issues and I am at a loss on how to rectify the issue. I have attempted a few different programs to unpark my core, with no effect. My Power settings from the Control Panel is set to High Performance. I have used msconfig > Boot > Advanced Options to set the number of processors to 2 with no effect. I have gone into BIOS to set my number of cores to 2 but I only have options of "All" or "1".

What am I missing here?

Thank you in advance for anyone who can assist.

0 Kudos
1 Solution
idata
Community Manager
493 Views

kylead: We will further assist you with this scenario.

 

 

Even though you mentioned you already set the option for the cores in the BIOS to "All", what we can try is to set the BIOS values to defaults and then run the Intel® processor diagnostics tool to confirm if now shows the 2 cores as working:

 

https://ark.intel.com/products/97455/Intel-Core-i3-7100-Processor-3M-Cache-3-90-GHz-

 

 

What is the model of the board?

 

We can always try a BIOS update to the latest version as well.

 

 

Regards,

 

Alberto R.

 

 

Intel Customer Support Technician

 

Under Contract to Intel Corporation

View solution in original post

7 Replies
idata
Community Manager
494 Views

kylead: We will further assist you with this scenario.

 

 

Even though you mentioned you already set the option for the cores in the BIOS to "All", what we can try is to set the BIOS values to defaults and then run the Intel® processor diagnostics tool to confirm if now shows the 2 cores as working:

 

https://ark.intel.com/products/97455/Intel-Core-i3-7100-Processor-3M-Cache-3-90-GHz-

 

 

What is the model of the board?

 

We can always try a BIOS update to the latest version as well.

 

 

Regards,

 

Alberto R.

 

 

Intel Customer Support Technician

 

Under Contract to Intel Corporation
KDayl
Beginner
493 Views

Thank you for your assistance, Alberto.

The default option in my BIOS for number of cores is "All". I don't imagine it will change the diagnostic results.

My board model is:

ASRock - B250M Pro4

I will attempt a BIOS update later today and report my results.

KDayl
Beginner
492 Views

Looks like the BIOS update did the trick. Thank you for your assistance!

KDayl
Beginner
493 Views

Though the core count appears correct in the Diagnostic Tool, when I change the number of processors in msconfig to 2 and restart, the Diagnostic Tool goes back to displaying only one physical core.

idata
Community Manager
493 Views

kylead: Thank you for sharing those results.

 

 

Based on the pictures from both task manager and the Intel® processor diagnostics tool the processor seems to be just fine, the tool does an overall test on the unit, so if it passed that test then it is working without problems.

 

Additionally, it is showing 2 physical cores on both pictures, that is the way the processor should be working.

 

 

According to ASrock's web site, the latest BIOS version available is 2.50, please try the BIOS update and let us know the results:

 

https://www.asrock.com/MB/Intel/B250M%20Pro4/index.asp# BIOS

 

 

Regards,

 

Alberto R.

 

 

Intel Customer Support Technician

 

Under Contract to Intel Corporation
KDayl
Beginner
493 Views

I had already done a BIOS update a few times with no change. In setting the number of processors in msconfig to 2, my system would boot showing only 1 physical core and 2 logical processes again. However, setting my number of processors in msconfig to 4 appears to have done the trick. So the question there isn't the number of physical cores, but actually the number of processes. Problem solved!

idata
Community Manager
493 Views

kylead: Thank you for sharing those results.

 

 

Excellent, thank you very much for letting us know that information, we are glad to hear the number of physical cores showing is correct now.

 

 

Any other inquiry, do not hesitate in contact us again.

 

 

Regards,

 

Alberto R.

 

 

Intel Customer Support Technician

 

Under Contract to Intel Corporation
Reply