Showing results for 
Search instead for 
Did you mean: 

Possible faulty CPU? i7 7820x

Hello all, I have a weird problem I was hoping someone might have insight into.

I just received my new alienware area 51 r4 desktop couple days ago (I know ewww yuck dell) and right out of the box I have had this odd problem. First thing I did was update all drivers and the bios, then used a few of the well known tools to test my hardware (memtest86, furmark, prime95, etc) along with the alienware stress test and check tools. Everything had passed all tests, so I then felt comfortable installing a few games and trying out the new rig. I tried 4 or 5 different games, and all of them froze up the computer and force restarted it. I checked the error code and they were the infamous hal.dll and ntoskrnl.exe BSOD. To be on the safe side and rule out a driver issue I then did a clean install of windows, installed all drivers and again tested some games. Same problem. I then downloaded the intel processor diagnostic tool and ran it, and it locks up on the prime numbers part of the test, and force restarts computer with what is seemingly the same BSOD error codes. I will be the first to admit I do not really know how to read the errors properly and accurately. I should add I have been watching temps throughout tests and gaming and nothing ever gets remotely close to hot inside the desktop, and nothing is overclocked as far as I know.

I contacted dell as the computer is 4 days old, and they seem to think the graphics card (gtx 1080ti) is bad and are working on an RMA as we speak. I just find it weird that the GPU passed all test, yet when I run the intel processor tool I can seemingly replicate the problem I have when I try to play games. I know this is a dell problem and I have to work with them, just thought maybe someone had some insights to maybe save some time with dell. Thanks for your time!


intel i7 7820x @ 3.6 ghz

32gb quad channel ddr4 @ 2933 mhz

nvidia gtx 1080ti

Toshiba 512 Gb m2 SSD

Seagate 2tb 7200rpm HDD

1500w alienware psu

Windows 10 64 bit

0 Kudos
2 Replies
Super User Retired Employee

Well, my gut reaction was look at the video card first (and memory as a distant second), so I generally concur with the approach being taken. Have you tried running the processor diagnostic test with the video steps disabled? Have you tried removing the video card and testing using the Intel HD Graphics engine (it obviously won't run every game, but at least it will allow you to (hopefully) do a full run of the processor diagnostic test).

Hope this helps,



Hello, thanks for the response.

How would i go about running the processor diagnostic tool with video steps disabled? When I open it, the test starts immediately and locks up at the prime numbers test section within 2-3 seconds. I will try removing the video card tonight and see what happens, thanks for the tip!