Community
cancel
Showing results for 
Search instead for 
Did you mean: 
rgord1
Novice
1,709 Views

Stop loading Intel Turbo Boost Max Technology 3.0 icon in notification area

Any way, other than third party tools, to stop Intel Turbo Boost Max Technology 3.0 from loading an icon in the Windows 7 x64 Notification Area?

I don't want to uninstall the application or driver, and preventing the service from loading at startup has no effect on the Notification Area icon.

0 Kudos
10 Replies
idata
Community Manager
264 Views

Hello raymondjpg:

 

 

As an option depending on the PC that you are using, if you can access the BIOS, there might be an option to disable turbo boost, you can try that, the icon on the notification area should disappear.

 

 

Or another option will be to customize the notification area by choosing which icons will appear or not in there, on the following link you will find the steps to do that, please scroll down until you see the instructions for Windows® 7:

 

 

http://www.howtogeek.com/75510/beginner-how-to-customize-and-tweak-your-system-tray-icons-in-windows... http://www.howtogeek.com/75510/beginner-how-to-customize-and-tweak-your-system-tray-icons-in-windows...

 

 

NOTE: These links are being offered for your convenience and should not be viewed as an endorsement by Intel of the content, products, or services offered there.

 

 

Also, you can always contact Microsoft to verify if there might be another option to manage or customize the notification area:

 

 

Microsoft's phone number: 1 800-642-7676

 

 

Microsoft's support site: https://support.microsoft.com/en-us https://support.microsoft.com/en-us

 

 

Any questions, please let me know.

 

 

Alberto

 

rgord1
Novice
264 Views

Thanks but disabling turbo boost in the bios would disable Intel Turbo CPU clock multiplier to 35x over stock 30x, and it is not turbo boost I want to disable.

I want to stop the Turbo Boost Max icon, for one core, from loading in the system tray.

It also appears that Microsoft is powerless to hide some program icons in the notification area, effectively hijacking it. Intel Turbo Boost Max appears to be one of these.

I have found that I can disable the executable ITBM.exe, but that is a sledgehammer approach. Better if Intel could provide an option to not show the Turbo Boost Max icon in the notification area in the first place, and some other way of opening the application..

Regards

idata
Community Manager
264 Views

Hello raymondjpg:

 

 

Thank you very much for letting us know that information.

 

 

We will take your suggestion under consideration, and I will send it to the proper department so they can get your feedback.

 

 

From our side, at this point the options above will be the things to try in order to hide the icon, this scenario is basically related to Windows itself, so to get a different work around, if that is possible, Microsoft should be able to provide further details about that.

 

 

Any questions, please let me know.

 

 

Alberto

 

rgord1
Novice
264 Views

Thank you.

Regards

idata
Community Manager
264 Views

Hello raymondjpg:

 

 

You are welcome.

 

 

Any other inquiry, do not hesitate in contact us again.

 

 

Regards

 

 

Alberto

 

GRowe2
Beginner
264 Views

Please help me hide the app in the taskbar. The app just stays open which is really annoying.

rgord1
Novice
264 Views

Change the name of the executable ITBM.exe in the directory C:\Program Files (x86)\Intel Corporation\Intel(R) Turbo Boost Max Technology 3.0 to something like ITBM.exe.disabled.

GRowe2
Beginner
264 Views

If I do that the program stops running, right? I want the program running.

rgord1
Novice
264 Views

You are right. I never found a way to hide the icon without disabling the executable, and Intel never got back to me with a solution. Perhaps you should start a new thread and see if Intel has anything new to offer.

DCzec
Beginner
264 Views

wtf?

just go to task scheduler in windows control panel and disable "Intel(R) Turbo Boost Max 3.0 Technology Application Launcher".

Thats it.

...or... WIN+R -> taskschd.msc

Reply