Processors
Intel® Processors, Tools, and Utilities
14914 Discussions

Z690/12th gen/13th gen bios updates causing Windows Activation issues

jonah255
Novice
1,435 Views

There are a fair amount of people having trouble with windows activation when updating they bios on z690 motherboards.  Are the manufacturers not flashing it properly? are they wiping out hardware identifiers? Please see the thread below:

 

https://answers.microsoft.com/en-us/windows/forum/all/windows-activation-after-bios-update/0f57a891-dd68-4aad-b18e-2009cee13b43

0 Kudos
4 Replies
AlHill
Super User
1,409 Views

The bios belongs to the motherboard manufacturer, not Intel.   Contact the motherboard manufacturer for assistance.

 

Doc (not an Intel employee or contractor)
[Maybe Windows 12 will be better]

jonah255
Novice
1,004 Views

Seems to happen across manufacturers of boards using intel chipsets particularly z690, z790:

 

Windows activation after bios update - Microsoft Community

Boards mentioned:

 

Gigabyte mobo (Z690 Aorus Pro)
Gigabyte Z690 AORUS ULTRA
Gigabyte Z690 Aorus Elite
Gigabyte Z690I A ULTRA LITE D4
Z690 Gigabyte UD AX
Gigabyte B760m AUROS Pro AX.
Gigabyte Z790 UD AC
GIGABYTE BOARD B760 DS3M AX
Gigabyte Z790
Gigabyte GA-Z790 Aorus elite
Gigabyte Z590 Arous Elite

MSI Z690 Carbon
MSI PRO Z690-A WiFi DDR4 ProSeries
MSI Z690 Edge Wifi DDR4
MSI Tomahawk Z690
MSI MPG Z690 Pro Carbon Wifi
msi meg Z790 ACE
MSI PRO-Z690-A-DDR4
MSI Z690-A
Z790 Mag Tomahawk wi-fi ddr5

Asrock z690 Extreme Wifi

 

Microsoft could use some help on this one it's been outstanding for years

 

0 Kudos
n_scott_pearson
Super User
986 Views

Al answered you correctly previously. The BIOS is developed and maintained by the motherboard manufacturer. Issues such as this are  thus the purview of these motherboard manufacturers.

If I was to speculate, this issue may be common to the three manufacturers because they are all using the same underlying BIOS core (from AMI, for example) and the issue is common within their releases of this core.

...S

jonah255
Novice
701 Views

Ah ok.  One thing that is interesting no one seems to report this issue for AMD boards and the mfg of my board, asrock, uses AMI bios for both their amd and intel boards.

0 Kudos
Reply