Processors (Intel® Core™, Intel® Xeon®, etc); processor utilities and programs (Intel® Processor Identification Utility, Intel® Extreme Tuning Utility, Intel® Easy Streaming Wizard, etc.)
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
12267 Discussions

i5-8400 Turbo Boost not working

Community Manager

I installed both Intel Turbo Boost Technology Monitor and CPU-Z and ran prime95 single core benchmark + gaming. In neither of the cases I was able to register Turbo Boost working (at all times the clock speed was capped at 2.8 GHz).

I made sure Turbo Boost is enabled in BIOS (I have ASRock Z370M-ITX/ac with latest BIOS version). My question is: is there any definitive way to confirm that Turbo Boost is working? How do I troubleshoot this issue?

Thank you!

0 Kudos
5 Replies
Community Manager

Phantom160: Thank you very much for contacting the Intel® Processor communities. We will do our best to assist you with this scenario.

In this case, we always recommend to install the latest BIOS version on the board and also the latest version of the chipset and management engine drivers: Download Download

In order to confirm that the Intel® Turbo Boost Technology is working, we can always run the Intel® processor diagnostics tool as well:

Additionally, on the link below you will find more details about the feature:

Any further questions, please let me know.



Alberto R
Community Manager

Hi Alberto,

Thank you for your reply. I confirmed that I have the latest BIOS (v.1.2) and Turbo Boost is enabled in BIOS. Further, I ran Intel processor diagnostics tool and I don't see any conclusive indicators that Turbo Boost is working. All clock speed monitors that I've used show 2.8 Ghz top speed. Please see below diagnostics report:

--- IPDT64 - Revision:

--- IPDT64 - Start Time: 11/15/2017 11:50:29 PM


-- Testing


CPU 1 - SPBC - Pass.

CPU 1 - Genuine Intel - Pass.

CPU 1 - BrandString - Pass.

CPU 1 - Floating Point - Pass.

CPU 1 - Prime Number - Pass.

CPU 1 - Cache - Pass.

CPU 1 - MMXSSE - Pass.

CPU 1 - FMA - Pass.

CPU 1 - AVX - Pass.

CPU 1 - IMC - Pass.

CPU 1 - PCH - Pass.

CPU 1 - IGD - Pass.

CPU 1 - GFX - Pass.

CPU 1 - CPULoad - Pass.

CPU 1 - CPU Frequency - Pass.

IPDT64 Passed

--- IPDT64 - Revision:

--- IPDT64 - End Time: 11/15/2017 11:55:30 PM


--- IntelR spbc Module Test --




..Retrieved Processor Manufacturer


..Retrieved Processor Brand String

IntelR CoreTM i5-8400 CPU 2.80GHz

IntelR spbc Module Test -- Pass --

--- Genuine Intel Test ---




Expected -- GenuineIntel

Detected -- GenuineIntel

Genuine Intel CPU Module Success

--- Brand String Test ---




Brand String Module Success....

--- Floating Point Test ---




AVX is supported in your OS

Max AVX supported AVX2

FMA3 supported

MFLOPS CycleRun Error Timesec

130.26 2004 0 1

205.205 5161 0 2

Million Floating Points per Second MFLOPS -- 205.205

Error -- 0

Floating Point Test Passed

--- Prime Number Generation Test ---




AVX is supported in your OS

Max AVX supported AVX2

Ops Per Sec CycleRun Error Timesec

127783 7 0 1

127401 14 0 2

Operation Per Second -- 127401

Error -- 0

Prime Number Generation Test Passed

--- Cache Test ---




--- Reading Cache Size ---

- Detected L1 Data Cache Size -- 32

- Detected L1 Inst Cache Size -- 32

- Detected L2 Cache Size -- 256

- Detected L3 Cache Size -- 9216

Cache Module Success

--- MMXSSE Test ---




--- Determining MMX - SSE capabilities ---


--- MMX SSE ---

MMX - Intel MMX Technology Supported -- Yes

SSE - Streaming SIMD Extensions Supported -- Yes

SSE2 - Streaming SIMD Extensions 2 Supported --Yes

SSE3 - Streaming SIMD Extensions 3 Supported --Yes

SSSE3 - Supplemented SSE 3 Supported --Yes

SSE4.1 - Streaming SIMD Extensions 4.1 Supported --Yes

SSE4.2 - Streaming SIMD Extensions 4.2 Supported --Yes

--- MMX SSE capabilities check complete ---

Testing MMX

Dot Product computed using C code 506

Dot Product computed using MMX intrinsics 506

MMX Dot Product Computation Test Passed

Passed MMX Test

Testing SSE

Dot Product computed using C code 506

Dot Product computed using SSE intrinsics 506

SSE Dot Product Computation Test Passed

Passed SSE Test

Testing SSE2

Complex Product computed using C code 23.00 -2.00i

Complex Product computed using SSE2 code 23.00 -2.00i

SSE2 Complex Product Computation Test Passed

Passed SSE2 Test

Testing SSE3

Complex Product using C code 23.00 -2.00i

Complex Product using SSE3 code 23.00 -2.00i

SSE3 Complex Product Computation Test Passed

Passed SSE3 Test

Testing SSSE3

SSSE3 Absolute Value Tests Passed

SSSE3 Arithmetic Tests Passed

SSSE3 Dot Product Test Passed

Passed SSSE3 Test

Testing SSE4.1

SSE4.1 Blend Tests Passed

SSE4.1 Min Max Tests Passed

SSE4.1 Insert Bit Tests Passed

SSE4.1 Extract Bit Tests Passed

SSE4.1 Bitwise Comparison Tests Passed

SSE4.1 Dot Product Test Passed

SSE4.1 Arithmetic Tests Passed

SSE4.1 Bit Conversion Tests Passed

SSE4.1 Bit Compare Test Passed

Passed SSE4.1 Test

Testing SSE4.2

SSE4.2 Bit Compare Test Passed

SSE4.2 Calculate Bit Set to 1 Test Passed

SSE4.2 CRC Test Passed

Passed SSE4.2 Test

MMXSSE Module Success

--- FMA3 Test ---




--- CPU Features Detection ---

FMA3 - Supported -- Yes

Testing FMA3....

FMA3 Test Resu...

Community Manager

Hi Phantom160: Thank you very much for providing that report. There is a setting on the BIOS on the Intel boards that is called Intel® SpeedStep that allows the clock speed of the processor to be dynamically changed by software. Please get in the BIOS and look for that option, if it is enabled, disable it or the other way round.



If after trying that step the problem persists or if the option it no showing on your BIOS, then the next thing to do, if you have the option of course, will be to test your board with a different processor or test your processor on a different board. Otherwise please get in contact directly with Intel to claim the warranty on the unit:


Chat support:,



For phone support, depending on your location, you will see the contact information on the links below:


EMEA contact information:


APAC contact information:


LAR contact information:


North America: Phone Number 1-916-377-7000, Monday – Friday 7:00 AM to 5:00 PM (Pacific Time).



Any questions, please let me know.





Alberto R


Community Manager

The new version of BIOS was posted on ASRock website yesterday (v1.5, posted on 11/28/2017). I updated the BIOS and the problem was solved. I confirmed that the CPU operates at clock speeds above 2.8GHz using CPU-Z right after restart, without running any benchmarks. As a matter of fact, the clock speed showed 4000MHz (which is an amazing improvement)

Community Manager

Phantom160: Perfect, excellent, thank you very much for letting us know that information, we are glad to hear the problem got fixed with the new BIOS from ASrock and now the PC is working properly.



Any other inquiry, do not hesitate in contact us again.





Alberto R