Community
cancel
Showing results for 
Search instead for 
Did you mean: 
npolu
Novice
1,479 Views

i7 7820x will not boost further than 4.0 Ghz

i7 7820x

Asus ROG STRIX E-Gaming Motherboard

My CPU will not boost further than 4.0 no matter what, I understand that its supposed to go up to 4.3 and 4.5 with Intel Boost 3.0 but it will not. I need some help on figuring this out.

I remember that my CPU would get up to 4.5 when I first got it, it no longer will even get to 4.3Ghz.

Latest BIOS udpated

Ran processor diagnostic tool

Intel Boost is enabled in BIOS

New intel boost 3.0 installed

Picture below is a screenshot while running a stress test on Intel Extreme Tuning Utility.

11 Replies
idata
Community Manager
205 Views

TSGoofy: Thank you very much for contacting the Intel® Processors communities. We will do our best to try to fix this problem.

 

 

In regard to your inquiry, we recommend to restore the BIOS settings to defaults. If the problem persists after that, please get into the BIOS and look for the option that is called Intel® Speedstep, make sure that option is enabled.

 

 

If the issue remains, then the next thing to do will be to get in contact directly with ASUS, to confirm if there is another setting that needs to be enabled on the BIOS for the Intel® Turbo Boost feature to work properly:

 

https://www.asus.com/us/support/ https://www.asus.com/us/support/

 

 

On the link below, you will find additional information about the feature:

 

https://www.intel.com/content/www/us/en/support/articles/000021587/processors.html https://www.intel.com/content/www/us/en/support/articles/000021587/processors.html

 

 

Any further questions, please let me know.

 

 

Regards,

 

Alberto R

 

npolu
Novice
205 Views

Thank you for the response.

Ive set the BIOS back to default once again and made sure the Turbo Boost was enabled as well as Intel Speed Step.

Ive messaged Asus about any other options that could be could be enabled but Ive gotten no help.

Talking to them did help me remember about one issue that Im stuck on and its a driver for my chipset I think.

KabyLake PCI Express Root Port # 10 - A2B1

This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

Ive tried to fix this issue but Ive had no luck, not even sure what it is. Can it be related to my problem?

n_scott_pearson
Super User Retired Employee
205 Views

No, that is a separate issue. To address it, download the latest release of the Intel Chipset Device Software package and extract the contents of the ZIP file to a folder on your hard drive. Open a DOS box at this folder and enter command

setupchipset.exe -overall

Reboot your machine after this is completed and the device should be working properly.

Hope this helps,

...S

n_scott_pearson
Super User Retired Employee
205 Views

Here is a link to the latest version that I could find: https://downloadcenter.intel.com/download/27099/NUCs-Intel-Chipset-Device-Software-for-Intel-NUC-Kit... Download Intel® Chipset Device Software.

...S

npolu
Novice
205 Views

Thank you for the information and the file although it says I already have the newest version and it asking if I want to Downgrade. I tried this method just a few days ago and it didnt fix my problem. Im willing to try again but I dont want to 'downgrade'.

n_scott_pearson
Super User Retired Employee
205 Views

Yes, you do. The version you are running is from Windows Update. We want to override that.

npolu
Novice
205 Views

Okay, I did that and the Exclamation went away so I guess thats fixed so thank you.

Still need help with the Turbo capped at 4.0Ghz Open to all suggestions

n_scott_pearson
Super User Retired Employee
205 Views

Good to know! I would recommend that you check this periodically for a while. If the problem came about as a result of a (later) update and this was installed by Windows Update, then it is possible that this issue could come back if that update is re-installed by Windows Update at some point. If this happens, let us know here so that we have have it looked at.

Unfortunately, I can't help you much with the Turbo issue other than to say that, in similar postings I remember seeing, the issue was the voltage control implemented on the motherboard. After raising the voltage slightly, their problems were resolved. I don't know of this is the cause of your issue, but is it certainly something worth looking at.

Hope this helps,

...S

npolu
Novice
205 Views

I did a CMOS reset and still nothing.

I switched my Voltage Jumper to allow more voltage and still nothing.

I added a photo of my BIOS menu, on the right it says my frequency is 4000 but on the top left it says its supposed to go up to 4500Mhz.

So.. Whats going on? I am so confused.

npolu
Novice
205 Views

n_scott_pearson
Super User Retired Employee
205 Views

I already answered you. If you do not understand the BIOS parameters, then you need to call your board manufacturer (i.e. Asus) and have them explain them to you. It is their BIOS and they are responsible for these types of questions.

...S

Reply