Showing results for 
Search instead for 
Did you mean: 

intel i5-7600k problem with turbo boost


I've recently bought a new desktop pc and it is equipped with an i5-7600k. I made some researces before buying it of course and once I had it all set I made a few benchmarks to test it. The pc is equipped with an nvidia 1060 6gb gpu, an Asrock z270 pro4 MB, 16gb ram ddr4 2400mhz, 1 ssd 240gb and 1hdd 1tb.

The i5-7600k should be at a base frequency of 3.8ghz and a max turbo boost frequency of 4.2ghz.

When only 1 core is being used its clock speed should then raise up to 4.2ghz, with 2-3 cores at 4.1ghz and with all 4 cores active at 4.0ghz. That of course without temp problems, which I don't have considering that during the benchmark temps were never abore 80°c (mostly in the 72-76 range).

The problem I found is that the max core speed of my cpu is being capped at 4.0ghz regardless of how many cores are being used. To test that I used many programs, like intel XTU, cpu-z and I also tried rendering something upon setting affinity on a single core. The result was that even when I could clearly see only one core at 100% usage and other sitting a 0% it was never, not even for half a second (in HWmonitor there is the "all time max" that would have registered it otherwise) it got past 4002 mhz.

I then tried to manually overclock it and I was able to achieve an higher clock. Even setting the "multi-core enhancement" from the MB was able to get it up to 4.2ghz but I still can't understand why without overclock it can't achieve the "stated" clock speed. I'd like not to use "overclock" of any sort... at least for now. What can I do to solve it? Has this happened to anyone else? Thank you for you time.

0 Kudos
2 Replies
Community Manager

Hello Kjeldoran,

Thank you for joining the Processors Community. I am sorry to hear you are having issues with this matter.

I checked the specification for your processor model and I noticed that the Intel® Turbo Boost Technology that comes included within your processors is the 2.0 version. This indicates that the feature will be reached whenever the processor needs it, basically the Intel® Turbo Boost Technology 2.0 accelerates processor and graphics performance for peak loads, automatically allowing processor cores to run faster than the rated operating frequency if they're operating below power, current, and temperature specification limits. Whether the processor enters into Intel® Turbo Boost Technology 2.0 and the amount of time the processor spends in that state depends on the workload and operating environment. And, the matter here and I believe is related to the behavior you are experiencing is that due to varying power characteristics, some parts with Intel® Turbo Boost Technology 2.0 may not achieve maximum turbo frequencies when running heavy workloads and using multiple cores concurrently. By overclocking the processor you are altering these variants and the processor is reaching the frequencies by being forced. Since overclocking voids the warranty, our recommendation at this stage is to update your BIOS version and all the pertinent drivers to the latest from ASRock site.

Hope this helps.



Amy C.

Community Manager

/thread/118684 Kjeldoran,

If you need further assistance let us know.


Amy C.