Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CLoon1
Beginner
782 Views

Altera Cyclone II Quartus II JTAG Programming Error

I'm trying to program a Cyclone II I bought here (https://rads.stackoverflow.com/amzn/click/B00LEMKR92) using Quartus II 13.0sp1 on Arch Linux. I'm trying to program it with a very simple Verilog program with three inputs and two outputs and a few simple logic functions. I selected the proper model (EP2C5T144C8), assigned the pins to the inputs/outputs, compiled, and ran the programmer. I am using a JTAG USB blaster. When I run jtagconfig, I receive the following output

1) USB-Blaster [2-1.6]   020B10DD EP2C5

 

However, when I try to program the .sof file created by the compiler, I receive the following error.

Error (209015): Can't configure device. Expected JTAG ID code 0x020B10DD for device 1, but found JTAG ID code 0x000310D9.

 

If I run the programmer multiple times, I often get different values for the ID code that it found. Does anyone know what's wrong here?

 

0 Kudos
1 Reply
Vicky1
Employee
34 Views

Hi,

"I am using a JTAG USB blaster. When I run jtagconfig, I receive the following output"

Since 'jtagconfig' command working correctly then this issue may occur due to following reasons,

  1. Check .sdc file name is same as project name or not, if available.
  2. Check the below link for cyclone II device,

https://www.intel.com/content/altera-www/global/en_us/index/support/support-resources/knowledge-base...

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/an/an039.pdf

https://datasheet.octopart.com/EP2C5T144C8-Altera-datasheet-7627975.pdf

 

I have not replicated this issue but I hope this might help to you.

 

Best Regards

Vikas Jathar 

(This message was posted on behalf of Intel Corporation)

 

 

Reply