Community
cancel
Showing results for 
Search instead for 
Did you mean: 
TJind
Beginner
518 Views

Altera USB Blaster II is not working properly while programming the third party winbond SPI flash

Hello,

 

We are using Cyclone-10 LP FPGA in our custom board. Winbond Flash part (W25Q64JVSFIQ) is used as a active config flash for FPGA.

 

Altera USB Blaster II is not able to program the winbond flash everytime. some times the winbond flash get programmed successfully but some times it gives different errors. The pass/fail ratio is 40%/60%.

 

Error type prints -

1) Error (209062): Flash Loader IP not loaded on device 1

2) Error (209075): Serial Flash Loader Active Serial Memory Interface on device 1 is not granted .

3) Error (209025): Can't recognize silicon ID for device 1. A device's silicon ID is different from its JTAG ID. Verify that all cables are securely connected, select a different device, or check the power on the target system. Make sure the device pins are connected and configured correctly.

 

I have attached the both pass and fail case prints with Altera USB Balster II.

 

Please let us know, what is the issue with Altera Blaster II that it is not programming the flash part everytime successfully?

 

Regards

Tarang Jindal

 

0 Kudos
1 Reply
YuanLi_S_Intel
Employee
182 Views

Hi Tarang,

 

There are few possibility for this. Can you try the following?

  1. Change the TCK frequency to 6MHz,
  2. Make sure the MSEL is in active serial mode.

 

Regards,

YL

Reply