Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
Announcements
Need Forum Guidance? Click here

Search our FPGA Knowledge Articles here.
18980 Discussions

Arria V GX (5AGXMB7) with Elpida DDR3 calibration passes, doesn't work

Altera_Forum
Honored Contributor II
973 Views

Hi! 

Has anybody tried working with Arria V GX Hard IP DDR3 UniPHY connected to a DDR3 successfully? 

In my case it is 5AGXMB7 connected to two Elpida (now Micron) EDJ4216EFBG-GN-F in x32 configuration on my custom board. 

The calibration for DDR3 passes successfully every time but the data on read gets corrupt after an arbitrary number of read commands. 

Same with the write operation. It stops writing after writing some number of words at a page. 

After changing a page the operation continues. 

Looks like the operations stop acting appropriately when they get overlapped by a refresh operation. 

Also the soft reset helps to resume normal operation for a small period. 

Any ideas on possible solutions?
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
119 Views

Found a memory device timing inconsistency.  

Works now. 

Thread closed.
Reply