Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
20704 Discussions

Basic NCO IP component for Cyclone IV cannot get simple sinewave

MMorr30
Beginner
563 Views

Hi,

 

I cannot get a simple sinewave out of the NCO IP on the cyclone 4. Below is the component from the IP Parameter editor.

 

pic1.png

 

Here is my instantiation:

 

nco u0k (

.clk     (CLK_125),    

.reset_n(1),

.clken    (1),   

.phi_inc_i  (34359738), 

.fsin_o   (sin_out),

.fcos_o  (),  

.out_valid  (ovalid)  

);

 

I am using the DE2i_150 board, Quartus 16.1, and the ADA board from Terasic for my DAC. I simply cannot get a sine wave out. Here is the best I can get:

 

pic2.png

 

Is my phase increment correct? It says so in the ip parameter editor. Do I need some sort of frequency modulation added? Is there a gain setting Im unaware of?

 

Thank you :)

0 Kudos
2 Replies
MMorr30
Beginner
437 Views

anyone?

0 Kudos
CheePin_C_Intel
Employee
437 Views

Hi,

 

sorry for the delay as the case has just been routed to me. As I understand it, you are observing some issue with the CIV NCO IP output. Just would like to check with you if you have had a chance to run a Modelsim simulation with your NCO IP to ensure the output is something matching your expectation? This would be helpful to isolate any functional behavior prior to hardware testing. In hardware, there are a number of other dependencies other than NCO IP.

 

Please let me know if there is any concern. thank you.

0 Kudos
Reply