Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
20775 Discussions

Cyclone 10 GX Devel. Kit Board Test System Failed

sfraser
Beginner
956 Views

Hello,

I just obtained the Cyclone 10 GX Dev Kit and am trying to use the provided Board Test System to test out the features on the board. I can connect to the board via USB and have installed the necessary drivers. However, when I try to configure the board to any of the provided .SOF files, I get the following error message:

"Failed to read production information from this SOF in the FPGA.
Please select compatible FPGA design from Configure option in the menu bar.
If you still meet this issue, please try to restart the BTS GUI."

Now obviously I have restarted the GUI and my PC, but the error persists. How can it be that the designs which are made specifically for only this development kit are not compatible?

If anyone has any experience using this program I'd be grateful for any help you can offer.

Thanks.

0 Kudos
4 Replies
AR_A_Intel
Employee
935 Views

Hi Sir

 

Welcome to INTEL forum. May we know is this the board that you use? https://www.intel.com/content/www/us/en/programmable/products/boards_and_kits/dev-kits/altera/cyclone-10-gx-development-kit.html

If not, could you advice. And could you also advice the following

1. Quartus version use

2. Pc OS version use

Thanks.


0 Kudos
AR_A_Intel
Employee
912 Views

We do not receive any response from you to the previous reply that I have provided. This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you


0 Kudos
A_G
Beginner
890 Views

Dear A,

I'm using the Cyclone 10 GX dev kit you mentioned (https://www.intel.com/content/www/us/en/programmable/products/boards_and_kits/dev-kits/altera/cyclone-10-gx-development-kit.html) in your reply. 

I have a similar problem where I get the "Failed to read production information ..." error 4 out of 5 times when it is configured with factory default design (GPIO/Flash: bts_config.sof). When it does work with GPIO/Flash firmware, if I were to configure it with any other example design (XCVR/DDR3/FMC) I always encounter the above error.

 

Could you please advice how to troubleshoot this issue.

Best regards

AG

0 Kudos
KeeganJ
Novice
733 Views

I struggled with this problem for about half a day so I'm sharing my solution.

 

The problem again was the BTS launched but after programming any of the samples it returns "Failed to read production information from this SOF in the FPGA".

 

The first issue was I had some older copy of the dev kit collateral .zip So go to the intel page for the cyclone 10gx dev kit and make sure you have the latest collateral archive.

 

Inside, the readme mentions you want to have Quartus prime pro 17.1 installed. So if you like me have a much newer version installed, make sure you download 17.1 and install it. They can be installed side-by-side.

 

However, there is another issue and when I launched BTS.exe I was getting an error about "invalid bit field" or something like that. The problem was the BTS program was not yet targeting the right quartus version. It gets the quartus install path from an environment variable QUARTUS_ROOTDIR. Go to your edit environment variables in windows and make sure that is set to C:\intelFPGA_pro\17.1\quartus. For me it was still pointing to a newer version of quartus. There is another env var QSYS_ROOTDIR = C:\intelFPGA_pro\17.1\qsys\bin which was already set correctly for me.

 

After that, I was able to run BTS .exe and program the dev kit and have it interact with the example designs succesfully.

0 Kudos
Reply