Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
1,016 Views

Cyclone II JTAG - SFL - EPCS4 problem

I have an EP2C20 Cyclone II connected to an EPCS4 Serial Loader Device. The FPGA is connected to a JTAG interface. I have been using the JTAG interface with success to program the Cyclone II. Now that I have a load that works the way I desire, I wanted to use the Serial Flash Loader Megafunction in Quartus II 10.0 SP1 (in Windows 7) to use the JTAG connection to load my program into the EPCS4.  

 

I convert my .sof file to .jic and the programmer automatically adds the SFL image when I add it to the programmer. The FPGA seems to program correctly with the SFL load, but the EPCS4 fails to load. I included a screen shot below. 

 

I double checked my schematic, and the setup with the JTAG Connector and the EPCS4 is correct according to Figure 13-25 in Altera's cyc2_cii51013.pdf. I included a pic of the schematic that shows the programming area. 

 

So, I loaded the SFL file (that comes with Quartus) directly to the FPGA, and then tried to auto-detect the EPCS4 through the ASMI interface. That also failed with an unexpected JTAG error of code 2. Screen shot included. 

 

So, does anyone see any obvious problems I'm missing? Any advice at all is appreciated. Thanks!
0 Kudos
4 Replies
Highlighted
Valued Contributor III
8 Views

see an 370 (http://www.altera.com/literature/an/an370.pdf). it might be usefull. 

 

I use sfl (noe_in input connected to gnd) for a cycloneIII/epcs4 and it works well.
0 Kudos
Highlighted
Valued Contributor III
8 Views

Yes, an370 was useful; it's how I got to where I am now. But it doesn't seem to have any troubleshooting help relevant to my situation. 

 

Thanks though.
0 Kudos
Highlighted
Valued Contributor III
8 Views

Well, I tried, just for the heck of it, converting my .jic file to a .jam file. And it worked! I have no idea why. But I checked it by power cycling and, sure enough, the FPGA loads and the board works fine.

0 Kudos
Highlighted
Valued Contributor III
8 Views

glad you make it works. I really not an expert in nios and I have never used .jam file, so I have no idea too... perhaps an error in convert programming files options or a quartus bug (many versions have a lot of problems with converting pgm files).

0 Kudos