Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
2,419 Views

DE0-Nano Control Panel connect problem

Hi, 

 

this is my first time use Altera fpga board, i copy the "DE0_Nano_ControlPanel" folder and try to run the application, it shows connection problem due to two missing file "jtag_client.dll" and "dinkum_alt.all",  

 

after copy two files from installation folder /bin directory, (why they don't include these two files in the folder?, user manual says just copy the folder and run the applicaiton.......)  

 

it shows "quartus_pgm download fail(0 sec), if click "ok",  

it shows "download SOPC file (DE0_Nano_ControlPanel.sof) fail! 

 

DE0_Nano_ControlPanel.sof is existing in the folder,  

 

so any idea what is going on there? 

 

Thanks, 

Bryce
0 Kudos
14 Replies
Highlighted
Valued Contributor III
394 Views

Bryce, 

I had a similar problem to yours. First, I downloaded the newest version of the Control Panel from Terasic. This only marginally helped in that it changed the error message slightly. What my problem was, was that the drivers weren't loaded for the DE0-Nano. It showed up in the device manager as a USB-Blaster. I updated the drivers through the update client in the device manager program by navigating to C:\altera\10.1\quartus\drivers and letting the computer install what it felt was appropriate. I am running windows 7 x64 professional. Hope that helps. 

Michael
Highlighted
Valued Contributor III
394 Views

Thanks! This helped. What a pain. I finally got my first FPGA project to load on the Deo-Nano! Others were saying it couldn't be done on windows 7 easily but this was easy.

0 Kudos
Highlighted
Valued Contributor III
394 Views

Hi guys, I'm have the same problem.  

I run Win7 (64bits), and I have followed guiding of miyoung1984.  

But I cann't solve this problem. 

 

Pls help me. Thanks so much!
0 Kudos
Highlighted
Valued Contributor III
394 Views

I encountered this problem with my DE2-115 as well. I installed the driver as described above and downloaded the latest Control Panel from Terasic, but ultimately resolved the problem by switching the switch on my DE2-115 from "PROG" to "RUN" mode (somewhat counterintuitively). 

 

If you have the latest Control Panel from Terasic, it will show you the command line it executes to program the device. Run this from the command line and you will receive debugging feedback from the programming tool. In my case the error message I got was: 

 

Error: CONF_DONE pin failed to go high in device 1 

Error: Operation failed 

 

--  

Derrick Coetzee
0 Kudos
Highlighted
Valued Contributor III
394 Views

miyoung1984 has the right answer. but remember to 'uninstall' the old driver before you install the new driver

0 Kudos
Highlighted
Valued Contributor III
394 Views

Nothing I do can fix this: 

Terasic DE0-Nano Control Panel V1.0.1 

jtagserver.exe 

The application was unable to start correctly (0xc00007b). Click OK to close the application. 

Anyone have an idea?
0 Kudos
Highlighted
Valued Contributor III
394 Views

I'm seeing the same problem, although I'm running Quartus 12.0sp2. Is that compatible with the DE0-Nano Control Panel? 

 

It might also be a problem with the USB-Blaster in general as I'm not able to run nios2-configure-sof from the command line successfully either.
0 Kudos
Highlighted
Valued Contributor III
394 Views

 

--- Quote Start ---  

I'm seeing the same problem, although I'm running Quartus 12.0sp2. Is that compatible with the DE0-Nano Control Panel? 

 

It might also be a problem with the USB-Blaster in general as I'm not able to run nios2-configure-sof from the command line successfully either. 

--- Quote End ---  

 

 

I found the answer in another thread. The problem is that the Altera JTAG Server service was not running. Guess that's not included/working in the standard Quartus install. If you download the stand-alone programmer (Quartus II Software Programmer - sorry, I can't post links yet) it will install the service and you should be good to go.
0 Kudos
Highlighted
Valued Contributor III
394 Views

I am getting the following error when setting up the control panel.  

 

quartus_pgm download fail (2 sec) 

download SOPC file(DEO-Nano-Control Panel.sof) fail 

 

Do I need to connect a usb blaster download cable to set up the DE0-Nano control panel? At the moment I am just using a USB Mini-B cable.
0 Kudos
Highlighted
Valued Contributor III
394 Views

I am getting the same error when setting up the control panel. I cannot seem to make any headway. 

 

quartus_pgm download fail (2 sec) 

download SOPC file(DEO-Nano-Control Panel.sof) fail 

 

Do I need to connect a usb blaster download cable to set up the DE0-Nano control panel? At the moment I am just using a USB Mini-B cable.
0 Kudos
Highlighted
Valued Contributor III
394 Views

I have encounered this problem also. 

And i solved this issue by the method provided by "miyoung1984 (http://www.alteraforum.com/forum/member.php?u=68592)". Thanks. 

 

The reason is that i did not install the "Altera USB-Blaster". 

The process is : Computer->Propertis->Device Manger-> a yellow mark is found ->" by navigating to C:\altera\10.1\quartus\drivers and letting the computer install what it felt was appropriate."(from miyong1984). 

 

My software version is "Quartus II 13.0 (64-bit) Web Edition".
0 Kudos
Highlighted
Beginner
394 Views

Follow the instructions in this link: http://www.terasic.com.tw/wiki/Altera_USB_Blaster_Driver_Installation_Instructions

 

For Windows 10, do the following:

  1. Plug the USB-Blaster into your PC.
  2. Open the Device and Printers (Control Panel | Devices and Printers).
  3. Under Unspecified, USB Blaster should be listed. Right mouse click on this and then select Properties.
  4. Select the Hardware tab and select Properties.
  5. A new window should pop up with the General tab already selected. Select Change Settings.
  6. Again a new window should pop up with the General tab already selected. Select Update.
  7. Select Browse my computer for driver software.
  8. Find <Path to Quartus II installation>\quartus\drivers\
  • (Note 1: Your altera file is located at the location you selected when you first installed quartus. The location listed in this document is the default location)
  • (Note 2: Stop at the drivers folder, i.e., do NOT go deeper by opening a folder within the drivers folder)
  1. Select OK. Make sure the proper path was selected then select Next.
  2. If the Windows security window pops up Check the Always trust software from “Altera Corporation”box and select Install.

For Windows 7 and Windows 8, do the following:

  1. Plug the USB-Blaster download cable into the PC. The following will appear on the screen: Device driver software was not successfully install. Select Click here for details.
  2. Select Change settings…
  3. Now cancel this (probably by selecting Cancel)
  4. Open the Device Manager (Windows Key | Control Panel | Device Manage)
  5. Under Other devices, USB Blaster should be listed. Right mouse click on this and then select Update Driver Software…
  6. Select Browse my computer for driver software
  7. Find <Path to Quartus II installation>\quartus\drivers\, then select Next; (Note: Stop at this folder, i.e., do NOT go deeper by opening a folder within the drivers folder)
  8. Check the Always trust … box and then select Install

 

0 Kudos
Highlighted
Beginner
394 Views

This worked for me on the DE10-Lite board as well.

 

When I ran this command:

.\bin64\quartus_pgm.exe -m jtag -c USB-Blaster[USB-0] -o "p;C:\Users\Michael Green\OneDrive\Documents\DE10-Lite-v.2.0.3_SystemCD\Tools\ControlPanel\DE10_Lite_ControlPanel.sof"

I got this error:

 

Error (213013): Programming hardware cable not detected

So with the board connected, I just reran this:

C:\IntelFPGA_lite\19.1\quartus\drivers\DPInst

I then relaunched the control panel and was able to connect to the board

Highlighted
Beginner
250 Views

Thanks to you,I was able to solve.

0 Kudos