Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
20803 Discussions

DE1-SOC Simulation Model Generation Failed on MegaWizard

akdrs
Novice
1,456 Views

Hello,

I'm trying to start a project with DE1-SoC and started from its own documentation.

https://fpgacloud.intel.com/devstore/platform/13.1.4/Standard/de1-soc-my-first-hps/

On the My First FPGA documentation, there is an IP package added via MegaWizard. I'm following the steps described in the document but when MegaWizard generates the core, an error occurs. It says: Error, Simulation model generation failed. I've tried the steps on different computers and different versions of Quartus but each one gives the same error. How can I solve that problem? Attached the model generation screenshot from the MegaWizard error.

0 Kudos
1 Solution
akdrs
Novice
1,234 Views

Hello again,

@ShengN_Intel thank you for your support to solve my problem. I've solved the problem by changing the character group. When compiling the projects or IP cores, Quartus tries to compile with system language. Anyone facing this problem in future can change the character set and solve the problem. We can mark the topic as solved.

View solution in original post

0 Kudos
10 Replies
sstrell
Honored Contributor III
1,443 Views

Do you need to generate simulation files for this?  Make sure simulation file generation is disabled.  I don't see in the project you linked to where this instruction is to generate this, but maybe I'm missing something.

Also, for some reason there are two slashes (//) in the middle of your path.  Not sure if that has anything to do with the issue.

0 Kudos
akdrs
Novice
1,432 Views

Hello again, 

Thank you for your answer. I don't need the simulation file generation for this study. Just I'm applying the steps shown in the getting started guide. How can I disable the simulation file generation? 

And yes, I say the two slashed at the report but I couldn't find the reason for that. In each version of Quartus, it's the same, the path after the Quartus folder has two slashes. Also, how can I correct this path? I've checked for the windows path environment but there's no slash there.

0 Kudos
ShengN_Intel
Employee
1,407 Views

You are following this manual http://www.ee.ic.ac.uk/pcheung/teaching/E2_experiment/My_First_Fpga.pdf right? 

I notice that you use Quartus v17.0 for the steps. Make sure to use Quartus v13.1 instead.

0 Kudos
akdrs
Novice
1,354 Views

Yes, I am following that manual (My_First_Fpga). I also tried on Quartus v13 and the result was the same. As sstrell said, I don't need the simulation file for this tutorial I think. But I don't know how to disable the simulation file generation. 

0 Kudos
ShengN_Intel
Employee
1,338 Views

Make sure .../17.0/quartus/sopc_builder/bin file exists in quartus installed directory and ip-make-simscript.exe exists as well in the bin file. The file is attached below just in case you need it. Or you can try reinstall the whole quartus.

I got something like yours if ip-make-simscript.exe is missing or removed. (Quartus Lite v17.0)

ShengN_Intel_0-1646234981936.png

0 Kudos
akdrs
Novice
1,318 Views

I've checked the folder and the file and they already exist. I added the screenshot of the installation directory as well. I've reinstalled the Quartus and also installed it on another computer with different versions. But the result is the same.

0 Kudos
ShengN_Intel
Employee
1,288 Views

Can you provide the project file for further debugging?

0 Kudos
ShengN_Intel
Employee
1,260 Views

Also, try to install the Quartus to local C disk see whether can resolve the problem or not.

0 Kudos
akdrs
Novice
1,235 Views

Hello again,

@ShengN_Intel thank you for your support to solve my problem. I've solved the problem by changing the character group. When compiling the projects or IP cores, Quartus tries to compile with system language. Anyone facing this problem in future can change the character set and solve the problem. We can mark the topic as solved.

0 Kudos
ShengN_Intel
Employee
1,222 Views

Appreciate for your sharing. It'll be great if you can mark it as solution for better future reference.

0 Kudos
Reply