Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
901 Views

Debugging active serial programming issue

I have strange issue: Cyclone 3 device with EPCS16 was programming properly before, now programmer says "can not recognize silicon ID". 

 

Programming device was replaced (USB blaster - ByteBlaster II) 

Cable was replaced. 

PC was rebooted. 

Two same boards with Cyclone and EPCS device experience this problem (only two are available). 

But at the same time device itself works and configures properly. 

There's small adapter board between cable and FPGA/EPCS board though, but its revision did not show any issue with it. 

 

I tried to "program" with cable disconnected, it says that same "can not recognize silicon ID", thus my guess that the issue above happens in very beginning of the programming process, probably some wire is broken (e.g. blaster can not shut FPGA down for programming). 

 

Is there any tool to see what exactly wrong goes on in the AS communication? At which step is is stuck, and thus what could be the cause?
Tags (1)
0 Kudos
3 Replies
Altera_Forum
Honored Contributor I
51 Views

In AS programming, the FPGA is not shut down, just the FPGA AS-interface tri-stated by driving nCE high. 

 

If you have also a FPGA JTAG interface available, you can try to write the flash through JTAG indirect programming instead. 

 

If you say, AS programming has worked before, what did you exactly change? PC software (e.g. JTAG drivers), board and programming hardware can matter.
Altera_Forum
Honored Contributor I
51 Views

 

--- Quote Start ---  

In AS programming, the FPGA is not shut down, just the FPGA AS-interface tri-stated by driving nCE high. 

--- Quote End ---  

 

Thank you. I did not investigate how it works exactly, probably that's why I ask this question. 

 

 

--- Quote Start ---  

If you have also a FPGA JTAG interface available, you can try to write the flash through JTAG indirect programming instead. 

--- Quote End ---  

 

I do not think so. It is connected using AS circuitry, there's place for JTAG connector, but it is not soldered in. 

 

 

--- Quote Start ---  

If you say, AS programming has worked before, what did you exactly change? PC software (e.g. JTAG drivers), board and programming hardware can matter. 

--- Quote End ---  

 

This is actually very good question. I have this issue remotely (not in my location), software is compatible Quartus 13.0.1 supporting the Cyclone 3. Interesting that same software with same blaster and even cable seem to work well on CPLD, but my guess that CPLD does not use active serial, that's why I ask for information where to dig (e.g. check some wire connectivity etc) - whatever which can shed light onto the issue. 

 

Edit: I have same programming device here, with same Quartus version, and it works. So I guess there should be really something wrong there.
Altera_Forum
Honored Contributor I
51 Views

CPLD programming is done via JTAG interface. AS programming uses additional pins on the 10 pin programming connector, it can be e.g. a broken cable or programmer defect. Or target board hardware defect.

Reply