Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
20693 Discussions

E-Tile Hard IP for Ethernet pin placement

yairs
Beginner
832 Views

Hi.

 

I am trying to build a 100GE Interface for a stratix10 tx device(1st280ey2f55i2lg). I have compiled successfully the example design, but I do not know how to change the location of the e-tile in order to match it to my board. The example design uses :

set_location_assignment PIN_REFCLK_GXER9C_CH1P -to i_clk_ref
set_location_assignment PIN_GXER9C_TX_CH0P -to o_tx_serial[0]
set_location_assignment PIN_GXER9C_TX_CH1P -to o_tx_serial[1]
set_location_assignment PIN_GXER9C_TX_CH2P -to o_tx_serial[2]
set_location_assignment PIN_GXER9C_TX_CH3P -to o_tx_serial[3]
set_location_assignment PIN_GXER9C_RX_CH0P -to i_rx_serial[0]
set_location_assignment PIN_GXER9C_RX_CH1P -to i_rx_serial[1]
set_location_assignment PIN_GXER9C_RX_CH2P -to i_rx_serial[2]
set_location_assignment PIN_GXER9C_RX_CH3P -to i_rx_serial[3]

 

and when I try to change it to any other tile, I am getting a fitter error. I couldn't find what are the restrictions for the e-tile selection. Please help.

 

Thanks

 

yair shapira

0 Kudos
1 Solution
ZiYing_Intel
Employee
535 Views

Hi yair,

 

It was the wrong pin assignment issue. You put 2 different signal in the same pin because you already

set_location_assignment PIN_REFCLK_GXER9C_CH1P -to i_clk_ref. For further information about E-tile hard IP, you may refer to link below https://www.intel.com/content/www/us/en/docs/programmable/683468/21-1/introduction.html

 

Since your issue has been resolved, I am now close the case. If you happen another issue after the case closed, please do feel free to submit another issue. There will have people reach out to you.

 

Best regards,

zying


View solution in original post

0 Kudos
9 Replies
ZiYing_Intel
Employee
770 Views

Hi yair shapira,


May I know that you try change to which tile?


Best regards,

zying


0 Kudos
yairs
Beginner
766 Views

Sure. Thanks for your help.

 

I tried (among other options that I do not remember ..) To move to tile 8B channels 0 - 3.

 

Yair,

0 Kudos
ZiYing_Intel
Employee
727 Views

Hi yairs,


Can you share the .qar file? So that I can try debug the issue from my side.


Best regards,

zying


0 Kudos
yairs
Beginner
718 Views

Hi.

 

Here it is.

 

Thanks for your help.

 

Yair

0 Kudos
ZiYing_Intel
Employee
691 Views

Hi Yairs,


Can you try achieve the project again? because the file that you share to me corrupted and don't have the .qsf and .qpf file inside it.


Best regards,

zying


0 Kudos
yairs
Beginner
681 Views

Hi.

 

I Archived again.

I am attaching the qsf and qpf also separately , just in case...

 

Thanks

 

yair shapira

0 Kudos
ZiYing_Intel
Employee
627 Views

Hi yairs,

 

I have a look and tried your .qar file from my side. It was the pin assignment issue. I made some changes on the pin assignment and it was compiled successfully from my side. 

0 Kudos
yairs
Beginner
584 Views

Thanks a lot , Now it compiles.

I saw that you made a change in one of the TBI Clocks placement. Could you please elaborate (or refer me to some document) , what is the usage of the TBI Clocks and what are their pin placement rules.

I am going to try to add at least one more 100GE ETILE IP, and probably some 10GE Interfaces in the future.

Thanks for all your help

yair

0 Kudos
ZiYing_Intel
Employee
536 Views

Hi yair,

 

It was the wrong pin assignment issue. You put 2 different signal in the same pin because you already

set_location_assignment PIN_REFCLK_GXER9C_CH1P -to i_clk_ref. For further information about E-tile hard IP, you may refer to link below https://www.intel.com/content/www/us/en/docs/programmable/683468/21-1/introduction.html

 

Since your issue has been resolved, I am now close the case. If you happen another issue after the case closed, please do feel free to submit another issue. There will have people reach out to you.

 

Best regards,

zying


0 Kudos
Reply