Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ISh
Novice
396 Views

I have a design that uses 10M16SAU169I7G. i noticed that every time I flash it, many I/Os (if not all of them) are going high, I even have a led connected that lights up.

i have done a blank check and even erased the device again, but nothing changes, still the device has many high voltage I/O's. 

my bank voltage is 3.3V. please advice why this happens and why the I/O's aren't Tri-stated?

0 Kudos
7 Replies
53 Views

can you check the configuration setting in the quartus ? There is options to enable / disable the Trisate . Also what you mean by all the IOs are not high state ? Can you clarify the same ? Thank you , Regards, Sree
ISh
Novice
53 Views

​configuration setting in the quartus is irrelevant because I am talking about a blank max10, a max10 that comes from the factory.

I assume it is the same as an erased one.

why aren't the output of the device at tri-state on a blank component?

 

thank you,

 

Itai

a_x_h_75
New Contributor III
53 Views

Blank, unprogrammed parts all have tri-state I/O with weak pull-ups.

Cheers,

Alex

53 Views

Hello Alex ,

Can you kindly point out in datasheet where it is mentioned ?

 

Thank you ,

 

Regards,

Sree

a_x_h_75
New Contributor III
53 Views

https://www.intel.com/content/www/us/en/programmable/documentation/mcn1397700832153.html#mcn13978112...

Table 17:

"Value of I/O pin (dedicated and dual-purpose) pull-up resistor before and during configuration, as well as user mode if the programmable pull-up resistor option is enabled"

 

Cheers,

Alex

ISh
Novice
53 Views

Thank you for the answer and pointing on the datasheet,

 

Though, I see that it is possible to change User I/Os weak pull up during configuration: https://www.intel.com/content/www/us/en/programmable/documentation/sss1393988509894.html#sss14260599... through changing the ICB settings.

Is it possible to configure the weak pull up also when the max10 is not configured? (for example , configuring the icb settings and then erasing the device)

 

Thanks, Itai.

a_x_h_75
New Contributor III
53 Views

This only affects the device during configuration. As soon as you erase the part these settings will have no effect.

 

Cheers,

Alex

Reply