Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
60 Views

Issues with 'sign_aocx' and 'clCreateProgramWithBinary'

Hello,

 

Recently the script for signing the bitstream of an aocx file has started failing. By failing I mean when I run "..linux64/libexec/sign_aocx.sh" with the proper arguments it runs halfway, stopping before the first 'aocl binedit' command. This pastebin shows which echo statements happen or happened. The reason this is an issue is that when I try and run a program with this half finished aocx it seg faults on the function clCreateProgramWithBinary.

 

A few things make this very confusing.

  • It started happening 1.5 weeks ago, before it worked fine
  • As far as I know nothing changed to cause it to stop working
  • It's only my user that this happens on.
    • If I send the .aocx file that can't be signed by me to a coworker and have them try on their 'instance' it works fine.

Some info about the system

  • The board we use is the pac10.
  • OpenCL 1.0 Intel(R) FPGA SDK for OpenCL(TM), Version 19.4.
  • OS is Ubuntu 18.04
  • I can find more details, I'm just not sure what I should provide.

 

Quick note for the point about 'instances' or 'users'. I don't really know what I'm talking about or that means, I just know what I SSH into, and log in. If I need to clarify this I can go find out the specifics

 

Could anyone give any suggestions as to a fix?

Thanks,
Keith

0 Kudos
1 Reply
Highlighted
22 Views

Hi ,

Please let us know whether the issue is still observed and whether it is seen in a cloud environment or not.

Thanks and Regards

Anil


0 Kudos