Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
Announcements
Need Forum Guidance? Click here

Search our FPGA Knowledge Articles here.

JTAG Connection

yuto
Beginner
171 Views

Hi.

How do I connect the JTAG pins?
I forgot to put a pull-up resistor on the board where I mounted the FPGA.
What kind of problems will occur if there is no pull-up resistor?

The circuit configuration is as follows.
Board A: FPGA mounted, no JTAG connector
Board B: JTAG connector mounted, with pull-up resistor.
Board A can work without Board B.

0 Kudos
1 Solution
YuanLi_S_Intel
Employee
145 Views

Hi Yuto,


For cyclone 10 LP, you may refer to pin connection guideline at link below:

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/dp/cyclone-10/pcg-01021.pdf


It would be better if you could follow the guidelines as stated for JTAG pin. The potential problem might be happening is on programming part.


Thank You.


View solution in original post

4 Replies
YuanLi_S_Intel
Employee
156 Views

Hi,


May i know which FPGA series are you using? Also, the pull up you are referring to which pin?


For your information, you may refer to our pin connection guidelines:

https://www.intel.com/content/www/us/en/programmable/documentation/lit-dpcg.html


Thank You.


Regards,

Bruce


yuto
Beginner
149 Views

Hello.
Thanks for your reply.

I use Cyclone10 LP.
After I finished designing the circuit, I noticed a mistake.
I would like to know what kind of problem will occur if there is no pull-up resistor on the JTAG pin.

I am worried if I can proceed with the debugging until I rebuild the board.

Best Regards.

YuanLi_S_Intel
Employee
146 Views

Hi Yuto,


For cyclone 10 LP, you may refer to pin connection guideline at link below:

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/dp/cyclone-10/pcg-01021.pdf


It would be better if you could follow the guidelines as stated for JTAG pin. The potential problem might be happening is on programming part.


Thank You.


View solution in original post

yuto
Beginner
126 Views

Hi.

Thank you for your answer.
I now understand that there could be a problem with the program.
I will fix the circuit.

Best Regards.

Reply