Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
19670 Discussions

MAX V Device ID failures

AL-D
Beginner
321 Views

we brokered some devices with the current material situation.

We purchased 400 pieces of 5M570ZT100C4N with date codes 1325 and 1337.

we had the parts tested prior to sending to our CM.  the test house provided the following data:

ALD_0-1646171791554.png

all passed with the correct device ID 

ALD_1-1646172265135.png

 

the parts are at our CM and they have a 66% failure at programing, failing the device ID check.

ALD_2-1646172446858.png

we are not sure why we have this issue since the parts were tested prior to programming.

 

0 Kudos
4 Replies
YuanLi_S_Intel
Employee
281 Views

It looks like you are using custom programmer to do programming. With 6/400 unit having issue only, it sounds to me that some of the part might have problem.


But anyway, what programming file you are programming? Also, is it possible to test with quartus programmer to do programming?


AL-D
Beginner
245 Views

thank you for the suggestions.  I will ask my CM if they have the quartus sw.

For programming they are currently using:

 

Manufacturer

Model

S/W

S/W Rev

Adapter

ELNEC

BeeHive204

Pg4uw

V3.38D

DIL48/QFP100 ZIF PLD-17

Data IO

PSV5000

TaskLink

V9.01

Q2861

 

they are using an .eprj project file Elnec for programming.

 

 

YuanLi_S_Intel
Employee
223 Views

Seems like .eprj is your own programming file. Could it be the file converting issue? Apologize that we are not able to support as we are only able to debug our own programming file issue such as SOF, POF, JIC and etc.


MBenca
New Contributor I
210 Views

Hi AL-D,

I would recommend to ask the same question in Elnec company via: www.elnec.com/en/support/problem-report/

Regards,

Martin

Reply