Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
Announcements
Need Forum Guidance? Click here

Search our FPGA Knowledge Articles here.
18480 Discussions

MAX10 Command line programming POF file does not work

rt52
Beginner
380 Views

I have a Max10 based custom board that I access remotely in order to perform tests.  I have installed the Quartus programmer for Linux (centos7) on this machine and can currently use the following command to program the board:

./quartus_pgm -m jtag -o "p;/<path to file>/<file>.sof" 

This command works, but only with .sof files.  Whenever I try to replace the .sof file with a .pof file, I get the following error

Error (209012): Operation failed
Info (209061): Ended Programmer operation at Mon Dec 14 16:18:16 2020
Error: Quartus Prime Programmer was unsuccessful. 1 error, 0 warnings
Error: Peak virtual memory: 567 megabytes
Error: Processing ended: Mon Dec 14 16:18:16 2020
Error: Elapsed time: 00:00:01
Error: Total CPU time (on all processors): 00:00:01

I would like to be able to switch to only using .pof files from now on but I can't program them remotely.  Can someone point to a document or command that will work in the command line for .pof files?

Related, launching the quartus_pgmw binary opens a blank gui window that never loads on linux.  I know how to consistently program .pof files with the gui window so getting quartus_pgmw to launch would work too.

Thank you

 

0 Kudos
4 Replies
RRomano001
New Contributor I
368 Views

 Hello, old version before presume 16.x was not suffering this issue.

 Try program a .sof in advance of .pof

 When .pof is sent to device programmer hang and jtagd deamon need be shut down.

 The only command work forever is erase.

 Blank check verify program fail no difference if Byte blaster is original one, terasic embedded or simple cheap china device.

 Also observed weird interaction with Saleae Logic8 and Stlink v2, when combined sometimes USB subsystem crash and you need reboot. Try'd init without success, only shutdown solve.

RRomano001
New Contributor I
366 Views

about quartus_pgmw checked on opt/altera where I wrote some note about issue on install,

check if this can solve graphic version

ln -s /lib64/libudev.so.1 /lib64/libudev.so.0
copy simlink on /lib/x86_64-linux-gnu/

 I am using Linux Mint and some new issue came from installation. Old good version 15.x is now broken and no more usable due to some recent library.

 Issue like resize before use pll still is present from 14.x. Programmer appeared after 15.x and year by year still landed to 20.x no difference if lite or pro.

rt52
Beginner
348 Views

1) .pof still does not work when programming .sof first.  I haven't seen the programmer hang forever, it will just fail with the error message, so I may not be experiencing the same issue.

2) This is on 19.1 version of programmer on Centos 7.  I tried your suggestion to link those 2 files but it still opens a blank gui window that never runs. Thanks for the suggestion, though

Do you know how to use IPS files from the command line?

RRomano001
New Contributor I
336 Views

Hello,

 Question 1: after attempt of programming a .pof file it accept a .sof or fail?
 can be of help check jtagconfig on fresh boot then after sending a .pof file to see if jtag server remain active or not.

 Question 2: launching from terminal see nothing on output relative to missing library or error?

 Lite_19_1 run smooth but output a huge warning about a missing lib "pixbuf" GdkPixbuf-CRITICAL

 lite 20_x run without errors but still doesn't program .pof.

 to program .pof you must go back to version 15 or previous, older version exhibit the empty windows you mention too. (checked now it work fine too like 19.x)

 Question 3:  its since 80th not use command line to program devices and never used IPS mode maybe one time when I embraced Altera near 2004 to automate maxII  programming.

 At last I suggest take an eye here to see if it cam be of some help:

https://sudonull.com/post/64660-JTAG-network-programmer-for-Altera-Quartus-Prime-from-Raspberry-Pi3

 

 Best wishes

Reply